ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Deepak Dixit <deepak.di...@hotwaxsystems.com>
Subject Re: Confusion in working with webpos
Date Mon, 24 Aug 2015 10:58:21 GMT
Thanks Pierre, 
I would like to commit the fix, and my preference is to add the missing code in header.ftl
file.
But first I would like to know your/Adrain's thought on this :)


Thanks & Regards
—
Deepak Dixit


> On Aug 24, 2015, at 4:24 PM, Pierre Smits <pierre.smits@gmail.com> wrote:
> 
> Hi Deepak,
> 
> Thanks. Will have a look at both.
> 
> Best regards,
> 
> Pierre Smits
> 
> *ORRTIZ.COM <http://www.orrtiz.com>*
> Services & Solutions for Cloud-
> Based Manufacturing, Professional
> Services and Retail & Trade
> http://www.orrtiz.com
> 
> On Mon, Aug 24, 2015 at 12:48 PM, Deepak Dixit <
> deepak.dixit@hotwaxsystems.com> wrote:
> 
>> Hi Pierre,
>> 
>> I replied to commit r#r1686655  to another thread for the same.
>> BTW its related to https://issues.apache.org/jira/browse/OFBIZ-6362
>> 
>> 
>> Thanks & Regards
>> —
>> Deepak Dixit
>> 
>> 
>> 
>> 
>>> On Aug 24, 2015, at 4:10 PM, Pierre Smits <pierre.smits@gmail.com>
>> wrote:
>>> 
>>> @Deepak,
>>> 
>>> Where is that piece of code missing? Shouldn't we raise a JIRA issue for
>>> this?
>>> 
>>> Best regards,
>>> 
>>> Pierre Smits
>>> 
>>> *ORRTIZ.COM <http://www.orrtiz.com>*
>>> Services & Solutions for Cloud-
>>> Based Manufacturing, Professional
>>> Services and Retail & Trade
>>> http://www.orrtiz.com
>>> 
>>> On Mon, Aug 24, 2015 at 12:30 PM, Deepak Dixit <
>>> deepak.dixit@hotwaxsystems.com> wrote:
>>> 
>>>> Hi Arjun,
>>>> 
>>>> This is working fine in ofbiz14.12 release. This is broken in trunk due
>> to
>>>> r#1686655. js files not loaded correctly due to mission js you webpos
>>>> functionality is broken.
>>>> 
>>>> For quick fix you can add the following code in header.fl after the
>>>> layoutSettings.VT_HDR_JAVASCRIPT inclusion:
>>>> 
>>>> {code}
>>>> <#if layoutSettings.javaScripts?has_content>
>>>>       <#list layoutSettings.javaScripts as javaScript>
>>>>           <script
>>>> 
>> src="<@ofbizContentUrl>${StringUtil.wrapString(javaScript)}</@ofbizContentUrl>"
>>>> type="text/javascript"></script>
>>>>       </#list>
>>>>   </#if>
>>>> {code}
>>>> 
>>>> 
>>>> Thanks & Regards
>>>> —
>>>> Deepak Dixit
>>>> 
>>>>> On Aug 20, 2015, at 4:41 PM, Arjun Rajappan <arjun.igenisis@gmail.com>
>>>> wrote:
>>>>> 
>>>>> Hi all,
>>>>> 
>>>>> Why still there is no reply for this mail ?
>>>>> Regards,
>>>>> Arjun R
>>>>> On Aug 15, 2015 4:12 PM, "Arjun Rajappan" <arjun.igenisis@gmail.com>
>>>> wrote:
>>>>> 
>>>>>> Hello everyone,
>>>>>> 
>>>>>> I am trying to work with webpos for past two days. Can't able to
>>>>>> understand it clearly and also some buttons are not working. And
>>>> keyboard
>>>>>> shortcuts are missing.
>>>>>> 
>>>>>> I am using Apache ofbiz version 12.04 which checked out from ofbiz
>>>> trunk.
>>>>>> 
>>>>>> I installed successfully with mysql database.
>>>>>> 
>>>>>> i opened ofbiz webpos via following url :
>>>>>> https://localhost:8443/webpos/control/main
>>>>>> 
>>>>>> i logged in with credentials admin as username and password as ofbiz
>> and
>>>>>> selected pos terminal 1.
>>>>>> 
>>>>>> Its successfully opened the webpos main screen.
>>>>>> 
>>>>>> Problem 1 : I am seeing keyboard shortcuts section at the top. *But
it
>>>> is
>>>>>> blank.*
>>>>>> 
>>>>>> Then i clicked on digital gizmo from the section "Products from this
>>>>>> catagory" it has added 1 quantity of digital gizmo to the cart with
>>>> price.
>>>>>> 
>>>>>> Problem 2: There is no buttons available for me to do rest of the
>>>> things.
>>>>>> How can i complete this payment process for this order.
>>>>>> 
>>>>>> Right side of the window we can see Select sales reps section :
>>>>>> Yes i do selected some of those
>>>>>> 
>>>>>> Problem 3 : once i selected what should i do. Where do i have to
>> click.
>>>> Or
>>>>>> what is the use of selecting sales reps.
>>>>>> 
>>>>>> Then i switched on to manager window.
>>>>>> 
>>>>>> I Clicked on open terminal. By response it has open a box and asking
>> for
>>>>>> opening "
>>>>>> Starting Drawer Amount
>>>>>> "
>>>>>> I have entered "1000" and clicked on Do you confirm? button.
>>>>>> 
>>>>>> Problem 4 : No response for the click in "Do you confirm" button.
Also
>>>> for
>>>>>> "cancel" button. And not any information to user. Or not any errors.
>>>>>> 
>>>>>> Same in the case of Close terminal , paid in and paid out. Except
shut
>>>>>> down.
>>>>>> 
>>>>>> And clicked on shut down button it successfully logged out.
>>>>>> 
>>>>>> Note : i am facing same problems in ofbiz-trunk-demo version also.
>>>>>> 
>>>>>> Did i got it wrong ??
>>>>>> 
>>>>>> Did i missed any pre-configurations ??
>>>>>> 
>>>>>> Please guide me with this problems i am facing.
>>>>>> 
>>>>>> Any help documents or configurations regarding my problem will be
>>>> welcome.
>>>>>> 
>>>>>> Thanks in advance.
>>>>>> 
>>>>>> Sorry for my bad English.
>>>>>> 
>>>>>> Find the screenshot in attachment.
>>>>>> 
>>>>>> Thanks
>>>>>> Arjun
>>>>>> 
>>>>>> 
>>>>>> 
>>>>>> 
>>>> 
>>>> 
>> 
>> 


Mime
View raw message