ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike <mz4whee...@gmail.com>
Subject Re: external install of multiple xml files through bash
Date Thu, 16 Apr 2015 18:42:17 GMT
Maybe use a script (like the one I pasted), add the classpath, and have the
service call the script instead of java directly.

On Thu, Apr 16, 2015 at 10:55 AM, Chris Clark <rip057@gmail.com> wrote:

> yeah i was hoping for something with the java command as i am going to try
> and run this as a service and my system doesnt, or should i say, didnt like
> ant when i was trying to make the ofbiz service... it does normally... just
> not in the service context
>
> Chris
>
> On Thu, Apr 16, 2015 at 12:42 PM, Mike <mz4wheeler@gmail.com> wrote:
>
> > Use this, modify to suit:
> >
> > root@srv01:/opt/ofbiz.import/bin# cat load_xml.sh
> > #! /bin/bash
> >
> > if [ ! -f "$1" ]; then
> >     echo "ERROR: finding $1"
> >     exit
> > fi
> >
> > #cd /opt/ofbiz
> > ./ant run-install-file -Ddata-file=$1
> >
> >
> > On Thu, Apr 16, 2015 at 10:04 AM, Chris Clark <rip057@gmail.com> wrote:
> >
> > > so i know i can do this..
> > >
> > > java -jar ofbiz.jar -install -file=file.xml
> > >
> > > although that doesnt work on my system i get
> > >
> > > Exception in thread "main" org.ofbiz.base.start.StartupException:
> > Couldn't
> > > not fetch config instance at
> > > org.ofbiz.base.start.Start.init(Start.java:202) at
> > > org.ofbiz.base.start.Start.main(Start.java:127) Caused by:
> > > java.io.IOException: Cannot load configuration properties :
> > > org/ofbiz/base/start/-install.properties at
> > > org.ofbiz.base.start.Config.getPropertiesFile(Config.java:229) at
> > > org.ofbiz.base.start.Config.readConfig(Config.java:297) at
> > > org.ofbiz.base.start.Config.getInstance(Config.java:58) at
> > > org.ofbiz.base.start.Start.init(Start.java:200) ... 1 more
> > >
> > >
> > > is this another one of those i didnt declare the classes thing?
> because i
> > > read in the classes and its still the same error... is there some
> > > idiosyncrasy to installing multiple files say from a directory...
> > >
> > > please help
> > >
> > > Chris
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message