ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ritu Raj Lakhera <rrlakh...@solveda.com>
Subject Content WYSIWYG Editor does not support the FTL syntax
Date Tue, 14 Jan 2014 06:48:18 GMT
Hi All, 

When I am changing the content in WYSIWYG Editor . This is loosing the FTL syntax after saving.


I tried with ' STDWRAP001 ' data resource. 
https://demo-trunk.ofbiz.apache.org:8443/content/control/EditHtmlText?dataResourceId=STDWRAP001

https://demo-trunk.ofbiz.apache.org:8443/content/control/EditElectronicText?dataResourceId=STDWRAP001


You can check this with 'WRAP_STD_001' data resource. 
https://demo-trunk.ofbiz.apache.org:8443/content/control/EditElectronicText?dataResourceId=WRAP_STD_001

https://demo-trunk.ofbiz.apache.org:8443/content/control/EditHtmlText?dataResourceId=WRAP_STD_001


For Ex: 
If content have the below text 
<#if x == 1> 
x is 1 
<#else> 
x is not 1 
</#if> 

and then go to WYSIWYG Editor, it becomes: 

&lt;#if x == 1&gt; 
x is 1 
&lt;#else / &gt; 
x is not 1 
<!--#if--> 

Is there a way to configure this WYSIWYG Editor to handle these idioms so that when I change
the data in this editor and a simple text area that the markup remains consistent? 

Regards 

Ritu Raj Lakhera 

Solveda India 
(formerly known as Salmon India) 
Phone. +91-9560087139 
Email. rrlakhera@solveda.com 
Skype. lakhera.rituraj 



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message