ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacques Le Roux <jacques.le.r...@les7arts.com>
Subject Re: missing data records from webtools in component and tenantcomponent entities
Date Fri, 15 Feb 2013 06:07:06 GMT
I guess you already read http://markmail.org/message/b7d5n5wsotiv7a3f and maybe http://markmail.org/message/5ft53p5bbgwhibdy
?
Apart that I don't know much about those entities

Jacques

From: "Black Bird" <blackbird1758@gmail.com>
> Thanks for your answer.  I've come across that JIRA issue many times.
> There is currently no resolution to that issue to my knowledge, and the
> only workaround being to disable the webtools application for tenants.
> 
> The issue I'm raising in this thread is different however, relating to the
> Component and TenantComponent entities, rather than the Tenant and
> TenantDataSources entities of JIRA 4130.  Even if a multitenant offering
> disabled webtools for a tenant as suggested by Hans, the provider would
> presumably still wish to utilise webtools with a main non-tenant admin
> login (i.e. tenantId=null).
> 
> 
> On Sun, Feb 10, 2013 at 12:25 AM, Jacques Le Roux <
> jacques.le.roux@les7arts.com> wrote:
> 
>> From: "Black Bird" <blackbird1758@gmail.com>
>> >I can answer my own last question.  Entries can be added into the
>> > 'component' entity using 'ant load-seed' process.
>> >
>> > The first question on data records from the component and tenantcomponent
>> > entities not being visible through webtools still holds however.  Does
>> > anyone experience this behaviour?
>>
>> You could be interested by this Jira
>> https://issues.apache.org/jira/browse/OFBIZ-4130
>>
>> Jacques
>>
>> >
>> > On Fri, Feb 1, 2013 at 4:54 PM, Black Bird <blackbird1758@gmail.com>
>> wrote:
>> >
>> >> I've been grappling with the multitenant capabilities of Ofbiz on
>> versions
>> >> 11.04, 12.04 and trunk.  I've realised that the 12.04 fork and trunk
>> have
>> >> introduced new entities 'component' and 'tenantcomponent' which I'm
>> trying
>> >> to learn how to utilise.
>> >>
>> >> What I've found strange is that on attempting to list the values of
>> these
>> >> two entities from webtools, only any record with the ComponentName
>> equal to
>> >> 'webtools' is visible.  On the other hand, if you log into the database
>> >> directly using ij, all the components can be seen using a select
>> statement
>> >> from the 'component' table, and any records entered manually into the
>> >> 'tenantcomponent' table.
>> >>
>> >> Also, by default, the 'find' screen for both these entities normally
>> comes
>> >> up with the 'ComponentName' field already populated with 'webtools'.
>> >>  Although the field can be emptied or replace with other component
>> names,
>> >> only the record pertaining to webtools can be returned.
>> >>
>> >> Is this a case of some hard-coding of ComponentName or am I missing
>> >> something?
>> >>
>> >> I'm using trunk r1439737 and 12.04 r1435045.
>> >>
>> >> I'm also unclear whether new components should be manually added to the
>> >> 'component' entity or should this happen automatically.
>> >>
>> >
>>
>

Mime
View raw message