ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacques Le Roux <jacques.le.r...@les7arts.com>
Subject Re: Ofbiz process gets killed abruptly without any clue
Date Fri, 01 Feb 2013 06:56:46 GMT
Makes sense, please open a Jira for that https://cwiki.apache.org/confluence/display/OFBADMIN/OFBiz+Contributors+Best+Practices

Thanks

Jacques

From: "Michael Alleblas" <malleblas@mookins.com>
>I think a check mechanism should be in place to detect such recursive
> loops. Since it can be inputted by an end user, it should be something
> checked for, especially considering the severity of the results.
> 
> 
> On Wed, Jan 30, 2013 at 8:52 PM, Vikas Mayur <vikasmayur@gmail.com> wrote:
> 
>> I don't think it a bug. It seems like you have setup product association
>> both ways i.e. from A (productId) to B (productIdTo) and from B (productId)
>> to A (productIdTo) which is causing the method to go in endless loop. The
>> correct way is to setup just one product association and the code will
>> abort as soon as the service getProductCost is invoked for product B.
>>
>> Regards
>> Vikas
>>
>> On Jan 30, 2013, at 11:23 AM, Deepak Agarwal wrote:
>>
>> > Found the bug. It was due to a never ending recursive call in
>> > getProductCost() simple method.
>> >
>> > Product A with cost 0
>> > Product B with cost 0
>> >
>> > A & B are variant
>> >
>> > Now, for product A when we call getProductCost() it calls getProductCost
>> > for product B (since it is one of it's variant) and product B calls for
>> > product A.
>> >
>> > Jdk 1.6_32 was exiting due to stack overflow.
>> >
>> > On Wed, Jan 30, 2013 at 7:55 AM, Varun Bhansaly <vbhansaly@gmail.com>
>> wrote:
>> >
>> >> What is the h/w configuration of the box on which OFBiz and DB are
>> hosted ?
>> >> What is the size of the database ?
>> >> Have you tried analyzing the JVM crash log files generated after the
>> crash
>> >> ?
>> >> Have you tried any of the memory profiling tools ?
>> >>
>> >> On Wed, Jan 30, 2013 at 1:22 AM, Deepak Agarwal <dagarwal82@gmail.com>
>> >> wrote:
>> >>> It's 100% consistent, tried from different hardwares. Everytime I
>> reserve
>> >>> inventory for a product the jvm gets killed without any trace.
>> >>>
>> >>> On Tue, Jan 29, 2013 at 2:46 PM, Deepak Agarwal <dagarwal82@gmail.com
>> >>> wrote:
>> >>>
>> >>>> Hi All,
>> >>>>
>> >>>> We have been running our store with following parameter for last
10
>> >> months:
>> >>>>        - requireInventory N
>> >>>>        - reserver inventory Y
>> >>>>        - balance inventory Y
>> >>>>        - check inventory   Y
>> >>>>
>> >>>> Now, suddenly ofbiz process is getting killed while reserving the
>> >>>> inventory. There is no foot steps , it simply just gets killed.
We
>> have
>> >>>> disabled this option but while packing we do require an inventory
>> >> reserved
>> >>>> else we can't pack.
>> >>>>
>> >>>> Any suggestions?
>> >>>>
>> >>>>
>> >>>> --
>> >>>> Thanks,
>> >>>> Deepak Agarwal,
>> >>>>
>> >>>> Mobile: +91 9501190044
>> >>>>
>> >>>
>> >>>
>> >>>
>> >>> --
>> >>> Thanks,
>> >>> Deepak Agarwal,
>> >>>
>> >>> Mobile: +91 9501190044
>> >>
>> >>
>> >>
>> >> --
>> >> Regards,
>> >> Varun Bhansaly
>> >>
>> >
>> >
>> >
>> > --
>> > Thanks,
>> > Deepak Agarwal,
>> >
>> > Mobile: +91 9501190044
>>
>>
>

Mime
View raw message