ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Parm Lehal <parmle...@gmail.com>
Subject Re: Ofbiz javascript behaves strangely with AJP
Date Fri, 28 Sep 2012 11:44:36 GMT
The files are loaded...that's why it is pointing to the error in the
javascript files with line numbers......... Is there anything else which
needs to be loaded other than three scripts in the script folder?

On Fri, Sep 28, 2012 at 4:37 AM, Rajbir Saini <rajbsaini@yahoo.com> wrote:

> It looks your JS is not loaded properly. Check page source and see if
> files are loaded.
>
> Thanks,
>
> Raj
>
>
> On Friday 28 September 2012 04:52 PM, Parm Lehal wrote:
>
>> I copied tried example ofbiz website within Ofbiz with and without AJP
>> (port 8009). Everything else works properly except that javascript
>> scripts for showing slides on the home page do not work with AJP.
>>
>> I get following errors:
>>
>>
>> Error: Prototype is not defined
>> Source File: http://localhost/xxxx/script/**effects.js<http://localhost/xxxx/script/effects.js>
>> Line: 73
>>
>> Error: $w is not defined
>> Source File: http://localhost/xxxx/script/**search.js<http://localhost/xxxx/script/search.js>
>> Line: 34
>>
>> Error: Class is not defined
>> Source File: http://localhost/xxxx/script/**slides.js<http://localhost/xxxx/script/slides.js>
>> Line: 20
>>
>> Error: document.observe is not a function
>> Source File: http://localhost/xxxx/#
>> Line: 104
>>
>> Everything works just fine on port 8080 and 8443........ What may be
>> wrong here? Please, advise.
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message