ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike <mz4whee...@gmail.com>
Subject Re: Installing clean new in MySQL 5.5.9
Date Wed, 09 Mar 2011 20:57:05 GMT
Try upgrading to the latest mysql-connector-java-*.jar and put it in:

OFBIZ_HOME/framework/entity/lib/jdbc


On Wed, Mar 9, 2011 at 12:43 PM, James Lawton <jamesl@tofinosoftware.com> wrote:
> Ahhh...just found a change in the MySQL manuals
>
> ====================================
>
> Section 5.1.7, "Server SQL Modes".
>
> Note
> The older TYPE option was synonymous with ENGINE. TYPE was deprecated in
> MySQL 4.0 and removed in MySQL 5.5. When upgrading to MySQL 5.5 or later,
> you must convert existing applications that rely on TYPE to use ENGINE
> instead.
>
> ======================================
>
>
> Does anyone know where I can change the TYPE to ENGINE in the Ofbiz code?
>
> James
>
> -----Original Message-----
> From: James Lawton [mailto:jamesl@tofinosoftware.com]
> Sent: March-09-11 3:39 PM
> To: 'user@ofbiz.apache.org'
> Subject: RE: Installing clean new in MySQL 5.5.9
>
> Thanks - you mean changing these in the entityengine.xml file, right?
>
> The error message below is from this statement
>
> CREATE TABLE CARRIER_SHIPMENT_METHOD (SHIPMENT_METHOD_TYPE_ID VARCHAR(20)
> CHARACTER SET latin1 COLLATE latin1_general_cs NOT NULL, PARTY_ID
> VARCHAR(20) CHARACTER SET latin1 COLLATE latin1_general_cs NOT NULL,
> ROLE_TYPE_ID VARCHAR(20) CHARACTER SET latin1 COLLATE latin1_general_cs NOT
> NULL, SEQUENCE_NUMBER DECIMAL(20,0), CARRIER_SERVICE_CODE VARCHAR(60)
> CHARACTER SET latin1 COLLATE latin1_general_cs, LAST_UPDATED_STAMP DATETIME,
> LAST_UPDATED_TX_STAMP DATETIME, CREATED_STAMP DATETIME, CREATED_TX_STAMP
> DATETIME, CONSTRAINT PK_CARRIER_SHIPMENT_METHOD PRIMARY KEY
> (SHIPMENT_METHOD_TYPE_ID, PARTY_ID, ROLE_TYPE_ID)) TYPE InnoDB CHARACTER SET
> latin1 COLLATE latin1_general_cs
>
> What's nagging at me is what is the syntax issue with the SQL statement? It
> was working in another install with MySQL 5.1 and isn't with a new install
> with MySQL 5.5.
>
> THoughts?
>
> James
>
> -----Original Message-----
> From: Mike [mailto:mz4wheeler@gmail.com]
> Sent: March-09-11 2:56 PM
> To: user@ofbiz.apache.org
> Subject: Re: Installing clean new in MySQL 5.5.9
>
> You probably want to dump the latin1 character set and use UTF8.  If you use
> latin1, you can forget about getting a multi-language capable ofbiz
> installation (I learned the hard way).  Try these:
>
>            table-type="InnoDB"
>            character-set="utf8"
>            collate="utf8_general_ci">
>
>
> On Wed, Mar 9, 2011 at 10:58 AM, James Lawton <jamesl@tofinosoftware.com>
> wrote:
>> I have just setup a brand new install on a machine with Windows 7 32
>> bit + MySQL 5.5.9
>>
>>
>>
>> After creating the databases and granting privileges to the user and
>> password named in the entityengine.xml file I ran the command:
>>
>>
>>
>> "ant run-install-seed" from the directory where ofbiz 10.04 OOTB is
>> installed - This install worked fine with MySQL 5.1.
>>
>>
>>
>> I get the following error back (actually tons of these errors)
>>
>>
>>
>> [java] Error was:
> com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException:
>> You have an error in your SQL syntax; check the manual that
>> corresponds to your MySQL server version for the right syntax to use
>> near 'TYPE InnoDB CHARACTER SET latin1 COLLATE latin1_general_cs'
>>
>>
>>
>>
>>
>> Has anyone seen this before?
>>
>>
>>
>> Dead in the water at this point
>>
>>
>>
>> Thanks
>>
>> James
>>
>>
>
>
>

Mime
View raw message