ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From f...@free.fr
Subject unable to bind RMIDispatcher (was: Re: ./startofbiz.sh doesn't start : JDK problem ?)
Date Wed, 13 Oct 2010 10:14:35 GMT
De Jacques Le Roux (6 October, 19:08) :

 > Be sure that  because you used ./startofbiz.sh before  OFBiz is not
 > already connected  to 1099 (though  sounds weird that you  get this
 > error without report by netstat!)

Doesn't seem  to be  so : netstat  doesn't report anything  neither on
1099 nor 8080 before (or after) invoking startofbiz.sh


 > When using ./startofbiz.sh you may look at the logs: runtime\logs

Well,  I'm not  sure what  to look  for in  the logs.  There's nothing
alarming about 1099.

I'm getting desperated : I've tried to change 1099 to 2099 or 11099 in   
  test-containers.xml, both-containers.xml, ofbiz-containers.xml,
  jndi.properties, jndiservers.xml, jetty-containers.xml,
  rmi-containers.xml
I always get the same error :

$ java -jar ofbiz.jar
.../...
2010-10-13 11:57:12,870 (main) [  GenericDispatcher.java:67 :INFO ] Creating new dispatcher
[RMIDispatcher] (main)
org.ofbiz.base.start.StartupException: Cannot start() org.ofbiz.service.rmi.RmiServiceContainer
(Unable to bind RMIDispatcher to RMI on //host[127.0.0.1]:port[11099]/name[RMIDispatcher]
- with remote=RemoteDispatcherImpl[UnicastServerRef2 [liveRef: [endpoint:[192.168.0.3:42641,org.ofbiz.service.rmi.socket.ssl.SSLServerSocketFactory@1f28e9fe,org.ofbiz.service.rmi.socket.ssl.SSLClientSocketFactory@18f5181e](local),objID:[4cb499a2:12ba505a399:-7fff,
302103791948159033]]]] (Exception creating connection to: 127.0.0.1; nested exception is:

	java.net.SocketException: Network is unreachable))
	at org.ofbiz.base.container.ContainerLoader.start(ContainerLoader.java:102)
	at org.ofbiz.base.start.Start.startStartLoaders(Start.java:272)
	at org.ofbiz.base.start.Start.startServer(Start.java:322)
	at org.ofbiz.base.start.Start.start(Start.java:326)
	at org.ofbiz.base.start.Start.main(Start.java:411)



 > BTW the demos trunk and stable are running on Ubuntu...

Damn it! amd64 ?


 > Also please send your messages to user ML only, it's enough for all
 > of us to get them ;o)

OK, sorry about that.


 > Jacques
 > 
 > From: <fdap@free.fr>
 > > Thanks to all for the quick replies.
 > >
 > > Summary :
 > > - 09.04 : compiles with either OpenJDK or Sun/Oracle
 > >          runs, from startofbiz.sh, with OpenJDK (!) only
 > > - 10.04 : compiles with Sun/Oracle only
 > >          doesn't run neither from startofbiz.sh nor from `java -jar ofbiz.jar'
 > >
 > > Details below.
 > >
 > >
 > > De pankaj savita (6 October, 14:43) :
 > >
 > >  > Check your class path entries for ofbiz10.04:
 > >  >
 > >  > JAVA_HOME
 > >  > C:\Program Files\Java\jdk1.6.0_20
 > >  >
 > >  > CLASSPATH
 > >  > C:\Program Files\Java\jdk1.6.0_20\lib;C:\Program
 > >  > Files\Java\jdk1.6.0_20\jre\lib
 > >  >
 > >  > PATH
 > >  > C:\Program Files\Java\jdk1.6.0_20\bin
 > >
 > > I dont' use Windows, but Debian Linux. With this distribution, JAVA_HOME and CLASSPATH
are not needed.
 > >
 > >
 > >  > Then  try to  bulid using  ant  run-install command  if its  build
 > >  > successfully start the server using java -jar ofbiz.jar.
 > >
 > > This works better than startofbiz.sh ( that is, errors occur later ;( ) :
 > >
 > > .../...
 > > 2010-10-06 16:28:38,053 (main) [  GenericDispatcher.java:61 :INFO ] Creating new
dispatcher [RMIDispatcher] (main)
 > > org.ofbiz.base.start.StartupException: Cannot start() org.ofbiz.service.rmi.RmiServiceContainer
(Unable to bind RMIDispatcher to 
 > > RMI on //host[127.0.0.1]:port[1099]/name[RMIDispatcher] - with remote=RemoteDispatcherImpl[UnicastServerRef2
[liveRef: 
 > > [endpoint:[192.168.0.3:51288,org.ofbiz.service.rmi.socket.ssl.SSLServerSocketFactory@6b030dea,org.ofbiz.service.rmi.socket.ssl.SSLClientSocketFactory@1586b489](local),objID:[-26f4a1d2:12b81f19bde:-7fff,

 > >  -3546405882729120089]]]] (Exception
 > > .../...
 > >
 > > Port 1099 doesn't seem to be used by another resource, since the command `netstat
-a | fgrep 1099' doesn't show anything.
 > >
 > >
 > >  > On Wed, Oct 6, 2010 at 2:39 PM, Jacques Le Roux <
 > >  > jacques.le.roux@les7arts.com> wrote:
 > >  >
 > >  > > You must use Sun (arg Oracle ;o) OpenJDK does not work with OFBiz yet...
 > >  > > Also try with ./ant rather (uses 1.7.1) I know there are some issues
with
 > >  > > 1.8
 > >
 > > Well, for the time being, only  OpenJDK allows me to use Ofbiz (9.04).
 > > Release 10.04 doesn't compile (OpenJDK) or doesn't run (Sun/Oracle).
 > >
 > > I've tried with ant 1.7.1, but it didn't change anything.
 > >
 > >
 > >  > On Wed, Oct 6, 2010 at 2:58 PM, Christian Geisert
 > >  > <christian.geisert@isu-gmbh.de> wrote:
 > >
 > >  > Have a look  at the value ADMIN_PORT in  startofbiz.sh, seems like
 > >  > something is wrong with this value.
 > >
 > > Here is what startofbiz.sh reads :
 > >  ADMIN_PORT=10523
 > >  ADMIN_KEY=so3du5kasd5dn
 > > Is this wrong ?
 > >
 > >
 > >
 > >  > >  Hello,
 > >  > >>
 > >  > >> Here is what I've done :
 > >  > >>  svn co http://svn.apache.org/repos/asf/ofbiz/branches/release10.04
 > >  > >>        Ofbiz-10.04
 > >  > >>  cd Ofbiz-10.04
 > >  > >>  ant run-install
 > >  > >>
 > >  > >> Here, I'm using the Sun (well, Oracle) jdk on a linux Debian amd64
laptop
 > >  > >> :
 > >  > >>  ~ § java -version
 > >  > >>  java version "1.6.0_21"
 > >  > >>  Java(TM) SE Runtime Environment (build 1.6.0_21-b06)
 > >  > >>  Java HotSpot(TM) 64-Bit Server VM (build 17.0-b16, mixed mode)
 > >  > >> The build is successful. Then, ./startofbiz.sh :
 > >  > >>
 > >  > >>  Set OFBIZ_HOME to - /srv/www/Ofbiz-10.04
 > >  > >>  Exception in thread "main" java.net.SocketException: Invalid argument
 > >  > >> at java.net.PlainSocketImpl.socketBind(Native Method)
 > >  > >> at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:365)
 > >  > >> at java.net.ServerSocket.bind(ServerSocket.java:319)
 > >  > >> at java.net.ServerSocket.<init>(ServerSocket.java:185)
 > >  > >> at org.ofbiz.base.start.Start.initListenerThread(Start.java:167)
 > >  > >> at org.ofbiz.base.start.Start.init(Start.java:93)
 > >  > >> at org.ofbiz.base.start.Start.main(Start.java:410)
 > >  > >>
 > >  > >> Same story with stable release 9.04.
 > >  > >>
 > >  > >> BUT, when I use OpenJDK :
 > >  > >>  ~ § java -version
 > >  > >>  java version "1.6.0_18"
 > >  > >>  OpenJDK Runtime Environment (IcedTea6 1.8.1) (6b18-1.8.1-2)
 > >  > >>  OpenJDK 64-Bit Server VM (build 16.0-b13, mixed mode)
 > >  > >>
 > >  > >> 9.04 builds successfully, and starts like a charm, whereas 10.04
fails
 > >  > >> to compile :
 > >  > >>
 > >  > >>  build:
 > >  > >>    [echo] [build] ========== Start Building Framework (Compile)
==========
 > >  > >>  .../...
 > >  > >>  classes:
 > >  > >>   [javac16] /srv/www/Ofbiz-10.04/common.xml:93: warning:
 > >  > >> 'includeantruntime' was not set, defaulting to build.sysclasspath=last;
set
 > >  > >> to false for repeatable builds
 > >  > >>   [javac16] Compiling 55 source files to
 > >  > >> /srv/www/Ofbiz-10.04/applications/product/build/classes
 > >  > >>   [javac16]
 > >  > >> /srv/www/Ofbiz-10.04/applications/product/src/org/ofbiz/product/product/ProductSearchSession.java:1231:
 > >  > >> cannot find symbol
 > >  > >>   [javac16] symbol  : method
 > >  > >> add(java.util.Map<java.lang.String,java.lang.Object>)
 > >  > >>   [javac16] location: interface
 > >  > >> java.util.List<java.util.Map<java.lang.String,java.lang.String>>
 > >  > >>   [javac16]
 > >  > >> featureCountList.add(UtilMisc.toMap("productFeatureId", (String)
 > >  > >> searchResult.get("pfacProductFeatureId"), "productFeatureTypeId",
(String)
 > >  > >> searchResult.get("pfcProductFeatureTypeId"), "description", (String)
 > >  > >> searchResult.get("pfcDescription"), "featureCount", Long.toString((Long)
 > >  > >> searchResult.get("featureCount"))));
 > >  > >>   [javac16]                             ^
 > >  > >>   [javac16] 1 error
 > >  > >>
 > >  > >>  BUILD FAILED
 > >  > >>  /srv/www/Ofbiz-10.04/build.xml:186: The following error occurred
while
 > >  > >> executing this line:
 > >  > >>  /srv/www/Ofbiz-10.04/applications/build.xml:67: The following error
 > >  > >> occurred while executing this line:
 > >  > >>  /srv/www/Ofbiz-10.04/macros.xml:27: The following error occurred
while
 > >  > >> executing this line:
 > >  > >>  /srv/www/Ofbiz-10.04/common.xml:93: Compile failed; see the compiler
 > >  > >> error output for details.
 > >  > >>
 > >  > >> I'm using ant 1.8 :
 > >  > >>  ~ § ant -version
 > >  > >>  Apache Ant version 1.8.0 compiled on March 11 2010
 > >  > >>
 > >  > >> Any idea ?
 > >  > >>
 > >  > >>
 > >  > >>
 > >  > >
 > >  > >
 > > 
 > 
 > 
 > 
 > 

Mime
View raw message