ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From BJ Freeman <bjf...@free-man.net>
Subject Re: MySQL DB creation with demo data
Date Tue, 31 Aug 2010 18:35:38 GMT
unfortunately I use postgres and don't have time to do a setup of mysql.
hopefully someone that is using mysql can help you further.

=========================
BJ Freeman  <http://bjfreeman.elance.com>
Strategic Power Office with Supplier Automation  <http://www.businessesnetwork.com/automation/viewforum.php?f=52>
Specialtymarket.com  <http://www.specialtymarket.com/>
Systems Integrator-- Glad to Assist

Chat  Y! messenger: bjfr33man


varun bhansaly sent the following on 8/31/2010 11:32 AM:
> I have tried with latest Connector/J 5.1.13, but result is the same (slow db
> creation)
>
> On Tue, Aug 31, 2010 at 11:58 PM, BJ Freeman<bjfree@free-man.net>  wrote:
>
>> that does make it more difficult.
>> Not sure what you can do, you might check if it is the MySQL jdbc driver
>> you using in ofiz. and possibly so setting the driver needs in the
>> entityengine.xml
>>
>>
>> =========================
>> BJ Freeman<http://bjfreeman.elance.com>
>> Strategic Power Office with Supplier Automation<
>> http://www.businessesnetwork.com/automation/viewforum.php?f=52>
>> Specialtymarket.com<http://www.specialtymarket.com/>
>> Systems Integrator-- Glad to Assist
>>
>> Chat  Y! messenger: bjfr33man
>>
>>
>> varun bhansaly sent the following on 8/31/2010 10:58 AM:
>>
>>   Thanks BJ, what is available is the 'target' m/c only with latest MySQL,
>>> no
>>> backup has been taken for this dev env.
>>> Since I work primarily with ofbiz, theres no other dataset to reference.
>>>
>>> On Tue, Aug 31, 2010 at 11:02 PM, BJ Freeman<bjfree@free-man.net>   wrote:
>>>
>>>   the first is to isolate if ofbiz is causing anything by removing it from
>>>> the equation.
>>>> so do a equivalent restore of data from the machine that ofbiz resides on
>>>> to the target that MySQL resides on and time.
>>>> you can do this by saving the MySQL data of a current db that has ofbiz
>>>> structure and data then loading like above to the db on the target
>>>> machine.
>>>> That give you a bench mark of the DB by itself.
>>>>
>>>> then setup ofbiz to a local db with the same setting as the remote one
>>>> and
>>>> see what the load time of the db is from ofbiz.
>>>>
>>>> that should give you a fair estimation where the problem is.
>>>>
>>>>
>>>>
>>>> =========================
>>>> BJ Freeman<http://bjfreeman.elance.com>
>>>> Strategic Power Office with Supplier Automation<
>>>> http://www.businessesnetwork.com/automation/viewforum.php?f=52>
>>>> Specialtymarket.com<http://www.specialtymarket.com/>
>>>> Systems Integrator-- Glad to Assist
>>>>
>>>> Chat  Y! messenger: bjfr33man
>>>>
>>>>
>>>> varun bhansaly sent the following on 8/31/2010 10:10 AM:
>>>>
>>>>   I have tried loading over network as well as from local.
>>>>
>>>>> Are talking of mysqldump restore as well ?
>>>>>
>>>>> On Tue, Aug 31, 2010 at 10:30 PM, BJ Freeman<bjfree@free-man.net>
>>>>> wrote:
>>>>>
>>>>>   if I read this correct you have introduced many variables.
>>>>>
>>>>>> 1) have you tested loading a MySQL db over the network in this
>>>>>> configuration, list a restore, not using ofbiz?
>>>>>> 2) have you tested loading a local MySQL db using ofbiz?
>>>>>>
>>>>>> =========================
>>>>>> BJ Freeman<http://bjfreeman.elance.com>
>>>>>> Strategic Power Office with Supplier Automation<
>>>>>> http://www.businessesnetwork.com/automation/viewforum.php?f=52>
>>>>>> Specialtymarket.com<http://www.specialtymarket.com/>
>>>>>> Systems Integrator-- Glad to Assist
>>>>>>
>>>>>> Chat  Y! messenger: bjfr33man
>>>>>>
>>>>>>
>>>>>> varun bhansaly sent the following on 8/31/2010 5:32 AM:
>>>>>>
>>>>>>   Hi,
>>>>>>
>>>>>>   I have setup 10.04 branch in my dev enviornment, with MySQL db
>>>>>>> server(v5.1.46 on a separate VM) with utf8 encoding on Open Suse
11.3
>>>>>>> having
>>>>>>> 4 processors&     2 gb ram.
>>>>>>> Encoding in entityengine.xml is set to utf8.
>>>>>>> Database creation with demo data takes minimum 40 minutes. Is
this an
>>>>>>> acceptable for db creation given above configuration ?
>>>>>>>
>>>>>>> PS : My previous MySQL server with latin1 encoding with 6 CPU
and 12
>>>>>>> gigs
>>>>>>> ram used to take 10 mins.
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>
>>>
>>
>
>


Mime
View raw message