ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacques Le Roux" <jacques.le.r...@les7arts.com>
Subject Re: getEntityFieldType(GenericDelegator.java:555) June 10th nightly builds localpostnew
Date Mon, 14 Jun 2010 05:57:13 GMT
You can debug in Eclipse without going through the boxes firewall.
https://cwiki.apache.org/confluence/display/OFBIZ/Running+and+Debugging+OFBiz+in+Eclipse#RunningandDebuggingOFBizinEclipse-Debugging(orrunning)OFBizinEclipse

Jacques

From: "BJ Freeman" <bjfree@free-man.net>
> thanks guess I have to figure out how to install eclipse on my centos box.
> can't do remote debug through the boxes firewall.
>
> =========================
> BJ Freeman
> http://bjfreeman.elance.com
> Strategic Power Office with Supplier Automation  <http://www.businessesnetwork.com/automation/viewforum.php?f=52>
> Specialtymarket.com  <http://www.specialtymarket.com/>
>
> Systems Integrator-- Glad to Assist
>
> Chat  Y! messenger: bjfr33man
> Linkedin <http://www.linkedin.com/profile?viewProfile=&key=1237480&locale=en_US&trk=tab_pro>
>
>
> Scott Gray sent the following on 6/13/2010 5:44 PM:
>> There isn't much code I haven't worked on or dug through now by this point :-) I'm
certainly not instantly familiar with all of 
>> it though.
>>
>> I cringe every time someone mentions using debug statements to identify the source
of a problem.  I would suggest that you learn 
>> how to perform remote debugging and insert breakpoints into the code, once you know
how you'll never look back.
>>
>> Uncomment this line in startofbiz.sh:
>> #DEBUG="-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=8091"
>> Setup a new debug configuration in eclipse of type "Remote Java Application" and
change the port to 8091
>> Insert a breakpoint on the line where you want to pause OFBiz, usually you can just
double click on the line number in the editor
>> Start OFBiz and launch the debug configuration
>> Wait for OFBiz to hit the breakpoint
>> Use eclipse to step through the code and see what is going on, the variables panel
will be your friend
>>
>> I use this on a daily basis.
>>
>> Regards
>> Scott
>>
>> On 14/06/2010, at 12:18 PM, BJ Freeman wrote:
>>
>>> I was hoping since you had worked with the code in this area you could point
me in what it was looking for and did not find.
>>> saves me having to put debug.info in to find out.
>>>
>>> =========================
>>> BJ Freeman
>>> http://bjfreeman.elance.com
>>> Strategic Power Office with Supplier Automation<http://www.businessesnetwork.com/automation/viewforum.php?f=52>
>>> Specialtymarket.com<http://www.specialtymarket.com/>
>>>
>>> Systems Integrator-- Glad to Assist
>>>
>>> Chat  Y! messenger: bjfr33man
>>> Linkedin<http://www.linkedin.com/profile?viewProfile=&key=1237480&locale=en_US&trk=tab_pro>
>>>
>>>
>>> Scott Gray sent the following on 6/13/2010 4:37 PM:
>>>> No sorry I can't help, I don't have the time right now to setup a local postgres
instance and figure what is going on.  I 
>>>> highly doubt the problem, if there is one, is related to anything I've committed
recently.
>>>>
>>>> Regards
>>>> Scott
>>>>
>>>> HotWax Media
>>>> http://www.hotwaxmedia.com
>>>>
>>>> On 14/06/2010, at 11:12 AM, BJ Freeman wrote:
>>>>
>>>>> just did a install of 10.4 using postresql and it is working fine.
>>>>> so what ever it is has to do with changes since 10.04 and June 10th.
>>>>> can you help Scott?
>>>>>
>>>>> BJ Freeman sent the following on 6/13/2010 12:50 PM:
>>>>>
>>>>>
>>>>> =========================
>>>>> BJ Freeman
>>>>> http://bjfreeman.elance.com
>>>>> Strategic Power Office with Supplier Automation<http://www.businessesnetwork.com/automation/viewforum.php?f=52>
>>>>> Specialtymarket.com<http://www.specialtymarket.com/>
>>>>>
>>>>> Systems Integrator-- Glad to Assist
>>>>>
>>>>> Chat  Y! messenger: bjfr33man
>>>>> Linkedin<http://www.linkedin.com/profile?viewProfile=&key=1237480&locale=en_US&trk=tab_pro>
>>>>>
>>>>>>
>>>>>> if I run it with derby it works fine.
>>>>>> I changed to localpostnew using 8.4.4 and it working fine with a
9.04
>>>>>> install
>>>>>> I was able to log into the db with psql so that all works.
>>>>>>
>>>>>> get the following error when it is trying to connect to db.
>>>>>>
>>>>>>
>>>>>>
>>>>>> [java] 2010-06-13 12:02:52,088 (main) [ ModelEntityChecker.java:502:INFO
>>>>>> ] [initReservedWords] array length=1023
>>>>>> [java] Exception in thread "main" java.lang.NullPointerException
>>>>>> [java] at
>>>>>> org.ofbiz.entity.GenericDelegator.getEntityFieldType(GenericDelegator.java:555)
>>>>>>
>>>>>> [java] at
>>>>>> org.ofbiz.entity.model.ModelEntityChecker.checkEntities(ModelEntityChecker.java:101)
>>>>>>
>>>>>>
>>>>>> looking at the code field-type-name="postnew"
>>>>>> public ModelFieldType getEntityFieldType(ModelEntity entity, String
>>>>>> type) throws GenericEntityException {
>>>>>> return this.getModelFieldTypeReader(entity).getModelFieldType(type);
>>>>>> }
>>>>>>
>>>>>> /* (non-Javadoc)
>>>>>> * @see
>>>>>> org.ofbiz.entity.Delegator#getModelFieldTypeReader(org.ofbiz.entity.model.ModelEntity)
>>>>>>
>>>>>> */
>>>>>> public ModelFieldTypeReader getModelFieldTypeReader(ModelEntity entity)
{
>>>>>> String helperName = getEntityHelperName(entity);
>>>>>> if (helperName == null || helperName.length()<= 0) {
>>>>>> return null;
>>>>>> }
>>>>>> that is about the best I can do so far.
>>>>>> any suggestions?
>>>>>>
>>>>>> =========================
>>>>>> BJ Freeman
>>>>>> http://bjfreeman.elance.com
>>>>>> Strategic Power Office with Supplier Automation
>>>>>> <http://www.businessesnetwork.com/automation/viewforum.php?f=52>
>>>>>> Specialtymarket.com<http://www.specialtymarket.com/>
>>>>>>
>>>>>> Systems Integrator-- Glad to Assist
>>>>>>
>>>>>> Chat Y! messenger: bjfr33man
>>>>>> Linkedin
>>>>>> <http://www.linkedin.com/profile?viewProfile=&key=1237480&locale=en_US&trk=tab_pro>
>>>>>>
>>>>>>
>>>>>>
>>>>
>>>
>>
> 



Mime
View raw message