ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Warnock <mwarn...@ridgecrestherbals.com>
Subject Re: compile error on trunk and 10.04, revision 945444
Date Tue, 18 May 2010 16:01:12 GMT
The machine in question is AMD Turion 64bit, 2 processors, 16GB of real
memory.  But I also see the same errors on my Core2 Duo laptop, running
Ubuntu 10.04, with 4GB memory.  That one *USED* to compile OK, but that
was like 2 months ago.

I am not doing anything to set memory requirements.  I don't have a
JAVA_HOME or ANT environment variable set, I thought on Linux that was
not required, am I wrong?  Like I said, it worked before, but maybe its
not seeing the right classpath.


-- 
Matt Warnock <mwarnock@ridgecrestherbals.com>
RidgeCrest Herbals, Inc.

On Tue, 2010-05-18 at 04:33 -0700, BJ Freeman wrote:
> Just compiled latest rev successfully.
> strange it would stop on that file since map is used in the framework
> which compiled fine.
> 
> how about memory on the machine?
> I have seen strange compile errors when the compiler runs out of memory.
> 
> 
> =========================
> BJ Freeman
> http://bjfreeman.elance.com
> Strategic Power Office with Supplier Automation <http://www.businessesnetwork.com/automation/viewforum.php?f=93>
> Specialtymarket.com <http://www.specialtymarket.com/>
> 
> Systems Integrator-- Glad to Assist
> 
> Chat  Y! messenger: bjfr33man
> Linkedin
> <http://www.linkedin.com/profile?viewProfile=&key=1237480&locale=en_US&trk=tab_pro>
> 
> 
> BJ Freeman sent the following on 5/18/2010 4:03 AM:
> > what the error says in that it can not find a certain class in the
> > classpath. my guess is the map method which would be in the JDK runtime.
> > 
> > as far as debian Adam Health is the one that puts Debian specific items
> > in.  Not sure he reads the user mailing list. Might give him a shout on
> > the dev ML.
> > 
> > I have not run 10;.04 on my centos which as Open JDK, but I doubt it is
> > the same distro as debian.
> > I am downloading through eclipse on to my dev machine it is slow.
> > so will let you know if it compiles, later this day.
> > 
> > 
> > =========================
> > BJ Freeman
> > http://bjfreeman.elance.com
> > Strategic Power Office with Supplier Automation <http://www.businessesnetwork.com/automation/viewforum.php?f=93>
> > Specialtymarket.com <http://www.specialtymarket.com/>
> > 
> > Systems Integrator-- Glad to Assist
> > 
> > Chat  Y! messenger: bjfr33man
> > Linkedin
> > <http://www.linkedin.com/profile?viewProfile=&key=1237480&locale=en_US&trk=tab_pro>
> > 
> > 
> > Matt Warnock sent the following on 5/17/2010 11:59 PM:
> >> Have tried it with and without "ant clean" before, usually running "ant
> >> run-install", but also various other "ant" and "./ant" targets. Not sure
> >> I understand the difference between ./ant and the system ant.
> >>
> >> Wish I understood the error messages better.  
> >>
> > 
> > 
> > 
> 


Mime
View raw message