ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Torstein Hegbom" <torst...@itpolaris.no>
Subject SV: Using port other than 8080
Date Thu, 04 Jun 2009 10:03:53 GMT
Nice, thank you.

Torstein

-----Opprinnelig melding-----
Fra: farouk alhassan [mailto:osbert252003@yahoo.com] 
Sendt: 4. juni 2009 11:51
Til: user@ofbiz.apache.org
Emne: Re: Using port other than 8080

Thats because you have another application running on that port.

you can use netstat command to find which program it is.

Regards

--- On Thu, 4/6/09, Torstein Hegbom <torstein@itpolaris.no> wrote:

From: Torstein Hegbom <torstein@itpolaris.no>
Subject: Using port other than 8080
To: user@ofbiz.apache.org
Date: Thursday, 4 June, 2009, 10:44 AM

I followed the advice of using port 28080, since the port 8080 was busy.
When running I get some problems going from https to http, where the port
changes from 8443 back to 8080, where it should change back to 28080.

 

Now when I am doing a restart after having changed all ports in all xml from
8080 to 28080, I get the following error:

 

ofbiz$ ./startofbiz.sh

Set OFBIZ_HOME to - /ofbiz

Exception in thread "main" java.net.BindException: Address already in use

        at java.net.PlainSocketImpl.socketBind(Native Method)

        at
java.net.AbstractPlainSocketImpl.bind(AbstractPlainSocketImpl.java:336)

        at java.net.ServerSocket.bind(ServerSocket.java:336)

        at java.net.ServerSocket.<init>(ServerSocket.java:202)

        at org.ofbiz.base.start.Start.initListenerThread(Start.java:159)

        at org.ofbiz.base.start.Start.init(Start.java:86)

        at org.ofbiz.base.start.Start.main(Start.java:398)

 

What has caused this problem? Do I need to ask the operation guys to restart
the server? Will that cure the problem?

 

Thanks

 

Torstein Hegbom




      


Mime
View raw message