ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arun Patidar <arun.pati...@hotwaxmedia.com>
Subject Re: Error during selecting orders for picking
Date Tue, 10 Feb 2009 13:19:21 GMT
yes this request is \using request-redirect. I traced this and found a 
solution for this in RequestHandler.java .If you allow then i can create 
a issue and upload a patch.

-Arun



Jacques Le Roux wrote:
> Is this request using a request-redirect ? I found already 2 others 
> cases where request-redirect seems to no longer appends a question 
> mark before URL parameters
>
> Jacques
>
> From: "David E Jones" <david.jones@hotwaxmedia.com>
>>
>> On Feb 9, 2009, at 11:08 PM, Arun Patidar wrote:
>>
>>> Hello All,
>>> I am facing a problem during selecting orders for picking. I am  
>>> working on latest revision 742839. Same problem also on demo site.
>>>
>>> I performed following steps:-
>>>
>>> 1:- created a sales order
>>> 2:- find list of orders by find orders tab in ordermgr
>>> 3:- select a sales order from list
>>> 4:- select pick orders option from drop down and then clicked on 
>>> Run  Action button.
>>>
>>>
>>> It gives  an error:-   
>>> org.ofbiz.webapp.control.RequestHandlerException: Unknown request  
>>> [findordershideFields=Y]; this request does not exist or cannot be  
>>> called directly.
>>
>> It looks like the URL is missing a question mark (?).
>>
>> Are you a developer? If so, the best way to resolve the issue you've  
>> raised is to look into the file (FTL or some widget def) and see 
>> where  this link is defined and what's up with it.
>>
>> I'm sure a patch to fix the issue will make it into the project  
>> quickly and resolve your issue. :)
>>
>> -David
>>
>
>


Mime
View raw message