ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Branden Strickland" <openforbusiness...@gmail.com>
Subject Re: Error when adding products to catagories
Date Mon, 03 Mar 2008 16:16:51 GMT
thanks!  I'll look them over really close.  I think I've seen them before,
but until now didn't seem all that important.

Guess I'll have to change my tune!

On Mon, Mar 3, 2008 at 11:13 AM, David E Jones <jonesde@hotwaxmedia.com>
wrote:

>
> http://ofbiz.apache.org/docs/entity.html
> http://ofbiz.apache.org/docs/entityconfig.html
>
> -David
>
>
> On Mar 3, 2008, at 8:54 AM, Branden Strickland wrote:
>
> > will do!
> >
> > Just out of curiosity, (so I can log it in my notebook) what is the
> > premise,
> > and or difference between the org.ofbiz and the org.ofbiz.olap?
> >
> > Thanks for the quick reply on that!
> >
> > I'll give it a shot while I anxiously await your reply.
> >
> > Thanks again!
> >
> > On Mon, Mar 3, 2008 at 9:57 AM, Jacopo Cappellato <tiz@sastau.it>
> > wrote:
> >
> >> Try with:
> >>
> >> <delegator name="default" entity-model-reader="main"
> >>  entity-group-reader="main" entity-eca-reader="main"
> >>  distributed-cache-clear-enabled="false">
> >>  <group-map group-name="org.ofbiz" datasource-name="localmysql"/>
> >>   <group-map group-name="org.ofbiz.olap" datasource-
> >> name="localmysql"/>
> >> </delegator>
> >>
> >> Jacopo
> >>
> >>
> >> Branden Strickland wrote:
> >>> David,
> >>>
> >>> I hate to keep bothering, and I'm obviously in no rush, but if you
> >>> have
> >> the
> >>> time, could you take a quick look at the entityengine.xml that I
> >>> have
> >> pasted
> >>> below and let me know if it looks legitimate. ?
> >>>
> >>> I suppose in the mean time, I'll have to to start commenting some
> >> components
> >>> out of the component-load in the special purpose directory, maybe
> >>> it's
> >> one
> >>> of those that isn't configured correctly?
> >>>
> >>> <connection-factory class="org.ofbiz.entity.connection
> >>>> .DBCPConnectionFactory"/>
> >>>>
> >>>>    <delegator name="default" entity-model-reader="main"
> >>>> entity-group-reader="main" entity-eca-reader="main"
> >>>> distributed-cache-clear-enabled="false">
> >>>>        <group-map group-name="org.ofbiz"
> >> datasource-name="localmysql"/>
> >>>>    </delegator>
> >>>>    <delegator name="default-no-eca" entity-model-reader="main"
> >>>> entity-group-reader="main" entity-eca-reader="main"
> >>>> entity-eca-enabled="false" distributed-cache-clear-enabled="false">
> >>>>        <group-map group-name="org.ofbiz"
> >> datasource-name="localmysql"/>
> >>>>    </delegator>
> >>>>
> >>>>    <delegator name="test" entity-model-reader="main"
> >>>> entity-group-reader="main" entity-eca-reader="main">
> >>>>        <group-map group-name="org.ofbiz"
> >> datasource-name="localmysql"/>
> >>>>    </delegator>
> >>>>    <delegator name="other" entity-model-reader="main"
> >>>> entity-group-reader="main" entity-eca-reader="main">
> >>>>        <group-map group-name="org.ofbiz"
> >> datasource-name="localmysql"/>
> >>>
> >>>
> >>> Thanks!
> >>>
> >>>
> >>> On Fri, Feb 29, 2008 at 5:49 PM, Branden Strickland <
> >>> openforbusinessman@gmail.com> wrote:
> >>>
> >>>> So This is unacceptable?! (see delegator section below)
> >>>>
> >>>> I'm not 100% sure how all of these work into the equation, but I
> >> figured
> >>>> if they all pointed to the same database then I'd be ok in the end
> >> right?
> >>>> If this is something I won't need just running a POS, which
> >>>> component
> >> should
> >>>> I turn off in the  component-load.xml file?
> >>>>
> >>>> Thanks gents!
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>> On Fri, Feb 29, 2008 at 11:47 AM, David E Jones <
> >> jonesde@hotwaxmedia.com>
> >>>> wrote:
> >>>>
> >>>>> It's in the entityengine.xml file, and there are examples there
> >>>>> that
> >>>>> include this package.
> >>>>>
> >>>>> -David
> >>>>>
> >>>>>
> >>>>> On Feb 29, 2008, at 7:48 AM, Branden Strickland wrote:
> >>>>>
> >>>>>> Delegator definition.  Gotcha.  Now, although I'm leaning how
to
> >> peice
> >>>>>> things together with ofbiz, I'm still a bit green around the
ears
> >>>>>> when It
> >>>>>> comes to technical names for documents.  Is the Delaegator
> >>>>>> definition in the
> >>>>>> file referenced in the error I posted in the first email?  Or
> >>>>>> is it
> >>>>>> in the
> >>>>>> entityengine or entitygroup?
> >>>>>>
> >>>>>> I'd love to take a quick look to see if i can fix it......That
> >>>>>> is....If I
> >>>>>> can find it! :P
> >>>>>>
> >>>>>> Thanks gents!  I'll start poking around anyway!
> >>>>>>
> >>>>>> Branden -
> >>>>>>
> >>>>>> On Fri, Feb 29, 2008 at 8:42 AM, Vince M. Clark <
> vclark@globalera.com
> >>>
> >>>>>> wrote:
> >>>>>>
> >>>>>>> BJ - This is a great question. We had a similar problem
where we
> >>>>>>> couldn't
> >>>>>>> complete an order because we didn't have the ebay component
in
> >>>>>>> specialpurpose. It is my feeling that specialpurpose components
> >>>>>>> should be
> >>>>>>> optional, and not break core functionality if they are missing.
> >>>>>>>
> >>>>>>> For example, when we deploy POS terminals we don't want
> >>>>>>> anything in
> >>>>>>> specialpurpose except the POS component. We don't need bi,
ebay,
> >>>>>>> etc. We
> >>>>>>> want our POS terminals lean.
> >>>>>>>
> >>>>>>> ----- Original Message -----
> >>>>>>> From: "BJ Freeman" <bjfree@free-man.net>
> >>>>>>> To: user@ofbiz.apache.org
> >>>>>>> Sent: Friday, February 29, 2008 3:58:03 AM (GMT-0700) America/
> >>>>>>> Denver
> >>>>>>> Subject: Re: Error when adding products to catagories
> >>>>>>>
> >>>>>>> this brings up a question if a main application should break
> >>>>>>> because a
> >>>>>>> specialpurpose apps is missing.
> >>>>>>>
> >>>>>>> David E Jones sent the following on 2/28/2008 9:31 PM:
> >>>>>>>> It's probably because in your delegator definition you
have no
> >>>>>>>> datasource mapping for the org.ofbiz.olap entity group
name.
> >>>>>>>>
> >>>>>>>> -David
> >>>>>>>>
> >>>>>>>>
> >>>>>>>> On Feb 28, 2008, at 4:32 PM, Branden Strickland wrote:
> >>>>>>>>
> >>>>>>>>> I'm running my DB on mysql.
> >>>>>>>>> Loaded sample data.
> >>>>>>>>> I've set up a new facility, catalog, and 2 catagories.
> >>>>>>>>>
> >>>>>>>>> I can't add products to either catigories. I get
this error.
> >>>>>>>>>
> >>>>>>>>> The Following Errors Occurred:
> >>>>>>>>>
> >>>>>>>>> Error calling event:
> >>>>>>>>> org.ofbiz.webapp.event.EventHandlerException:
> >>>>>>>>> Service
> >>>>>>>>> invocation error (Could not commit transaction for
service
> >>>>>>>>> [createProduct]
> >>>>>>>>> call: Roll back error, could not commit transaction,
was
> >>>>>>>>> rolled
> >>>>>>>>> back
> >>>>>>>>> instead
> >>>>>>>>> because of: Error in simple-method [
> >>>>>>>>>
> >>>>>>> [file:/home/bstrickland/svnWS/ofbizdemo/specialpurpose/bi/
> >>>>>>> script/
> >>>>>>> org/ofbiz/bi/
> >>>>>>> DimensionServices.xml#prepareProductDimensionData]]:
> >>>>>>>>> Error running the simple-method: Error in simple-method
> >>>>>>>>> operation
> >>>>>>>>> []:
> >>>>>>>>> java.lang.IllegalArgumentException: Type id-ne not
found
> >>>>>>>>> null)
> >>>>>>>>> I looked at the DemensionServices.xml and couldn't
tie
> >>>>>>>>> anything
> >>>>>>> together.
> >>>>>>>>>
> >>>>>>>>> Also (un related)
> >>>>>>>>>
> >>>>>>>>> In the business setup document, it suggests you
create 4
> >>>>>>>>> catagories,
> >>>>>>> and
> >>>>>>>>> this confused me as well. Is there a purpose for:
> >>>>>>>>> Browse Root Category
> >>>>>>>>> Top-level browse category
> >>>>>>>>> Promotions Category
> >>>>>>>>> "all Products" ategory as default search.
> >>>>>>>>>
> >>>>>>>>> Thanks gentlemen!
> >>>>>>>>
> >>>>>>>>
> >>>>>>>>
> >>>>>>>
> >>>>>
> >>>
> >>
> >>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message