ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sumit Pandit" <ssumitpan...@gmail.com>
Subject Getting problem in <add-error...> & <check-error>
Date Wed, 06 Feb 2008 06:58:03 GMT
Hello All,

Look at this code :-

controller entry :-
    <request-map uri="showFixedAssetDepreciation">
        <security https="true" auth="true"/>
        <event type="simple" invoke="calculateFixedAssetDepreciation"
path="org/ofbiz/accounting/fixedasset/FixedAssetServices.xml"/>
        <response name="success" type="view"
value="ShowFixedAssetDepreciation"/>
        <response name="depreciationMtdNotAvail" type="request"
value="depreciationMethodAssignment"/>
        <response name="error" type="view"
value="ShowFixedAssetDepreciation"/>
    </request-map>

For such responce i use following code in simple method :-
    <add-error><fail-property resource="AccountingUiLabels"
property="AccountingReqDepMtdAssignment"/></add-error>
     <check-errors error-code="depreciationMtdNotAvail"/>

After execution of these lines the code is returned successfully and request
"depreciationMethodAssignment" is called properly but the error message
which I added is not being displayed.  But if I simply use <check-errors/>
than the added error is displayed properly.

Can some one suggest me that if i missed something.

Thanks for suggestion.

-- 
Sumit Pandit

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message