ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brendan Vogt" <brendan.v...@gmail.com>
Subject RE: entityengine.xml Validation Error
Date Tue, 01 Jan 2008 16:41:49 GMT
I didn't change anything.

-----Original Message-----
From: Scott Gray [mailto:lektran@gmail.com] 
Sent: Sunday, December 30, 2007 10:46 PM
To: user@ofbiz.apache.org
Subject: Re: entityengine.xml Validation Error

It's saying that the xml isn't structured the way the entity-config.xsd says
it should be.  You should have a connection-factory tag before any delegator
tags, both 4.0 and trunk are correct.  If you're using Subclipse for svn
then you should be able to right-click on entityengine.xml -> Compare with
-> Base revision, and see what you've changed.

Regards
Scott

On 31/12/2007, BJ Freeman <bjfree@free-man.net> wrote:
>
> my first response is, if the program is running and your not getting
> errors in the UI or in the logs, then don't worry about it.
>
> however if your curious why XML Buddy is giving you this error, then I
> suggest you go to their forum and ask.
> I am using xml buddy 2.0.72 and don't get an error in ofbiz ver 4.0
>
> Brendan Vogt sent the following on 12/30/2007 5:55 AM:
> > Hi,
> >
> >
> >
> > I need to know if this is a bug that I/we need to worry about?
> >
> >
> >
> > On line 48 the code looks like this:
> >
> >
> >
> > <delegator name="default" entity-model-reader="main"
> > entity-group-reader="main" entity-eca-reader="main"
> > distributed-cache-clear-enabled="false">
> >
> >
> >
> > The error that I get with XML Buddy in Eclipse is something like:
> >
> >
> >
> > Error - cvc-complex type.2.4.a: Invalid content was found starting with
> > element 'delegator'.  One of '{""connection-factory}' is expected.
> >
> >
> >
> > What is this error, I have never seen it.
> >
> >
> >
> > Brendan
> >
> >
>
>


Mime
View raw message