ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Si Chen <sic...@opensourcestrategies.com>
Subject Re: ofbiz database connection , minerva ???
Date Mon, 02 Oct 2006 17:16:58 GMT
Tibor,

Minerva was replaced by the Geronimo transaction managers in ofbiz  
back in May of this year, but opentaps 0.9 still uses JOTM for  
transaction management.  The next version of opentaps should  
incorporate the newer transaction manager currently used by the SVN  
version of OFBiz.  The reason this was done was actually for  
licensing reasons, not for any technical reasons that I'm aware of.

I think the problem you are experiencing may be more related to  
PostgreSQL than to the transaction manager layer of opentaps and  
OFBiz.  Even OFBiz 3.0 and 3.1, which are a year older than opentaps  
0.8.3, could be scaled up with the right configuration of the  
database.  At some volume of connections, though, PostgreSQL would  
have to be clustered.  Have you checked whether PostgreSQL is still  
running successfully?

Si


On Sep 29, 2006, at 8:02 AM, tibor katelbach wrote:

> Hi everyone
>
> We are test running our production site with JMeter test and  
> multiple users,
> orders... and
> we are having trouble with DB connections (as below) , it seems to  
> appear
> when some orders are created?
> config :
> Postgres 8.0.3 and 8.1, sequoia 0.8.3
>
> we have a few ideas maybe someone has a real experience to share  
> with us ?
>
>
>   - we noticed when the server swaps this seems to cause more errors ?
>
>
>   - we seem to have numerous  deadlocks , has any have some experience
>   with such errors ?
>
> (even with entity engine config as pool-deadlock-maxwait="300000"
> pool-deadlock-retrywait="10000"  pool-minsize="200" pool- 
> maxsize="200")
>
>   - Minerva was pulled out of the new version of Sequoia, is this
>   correct and why ? should we swap it ?
>
>
>   - Is Geronimo a solution for replacing Minerva, I thought it was  
> only
>   a container ?
>
> Any help on this would be more than welcome
> Best Regards
> Tibor
>
>
> I read a few threads about the errors below but precise answer
>
> Can't get an XAConnection
>
> 52788 (invoker-Thread-7) [         ObjectPool.java:632:ERROR]  
> Exception in
> creating new object for pool
> java.lang.RuntimeException: Could not create connection
>
> 52793 (invoker-Thread-7) [  ConnectionFactory.java:65 :ERROR]
> ---- runtime exception report
> --------------------------------------------------
> There was an error getting a Minerva datasource.
> Exception: java.lang.RuntimeException
> Message: Could not create connection


Mime
View raw message