ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kurt T Stam" <k...@osConsulting.org>
Subject multiple websites configuration
Date Tue, 03 Oct 2006 14:15:07 GMT
Hi guys,

I'm a little confused how to set up multiple websites on ofbiz. Under
applications I see the ecommerce directory. In it I see a webapp
directory. It contains the ecommerce webapp. I copied this directory and
called is webapp2. Then I modified the ofbiz-component.xml to read:

  <webapp name="ecommerce"
        title="ECommerce"
        server="default-server"
        location="webapp/ecommerce"
        mount-point="/ecommerce"
        app-bar-display="false">
 <virtual-host host-name="admin.mydomain.com"/>
     </webapp>
  <webapp name="ecommerce2"
        title="ECommerce2"
        server="default-server"
        location="webapp/ecommerce2"
        mount-point="/"
        app-bar-display="false">
 <virtual-host host-name="www.mydomain.com"/>
     </webapp>

And I modified the web.xml of ecommerce2 to contain the unique id values
of the new website.

It all seems to work ok, except when a user wants to log into the
ecommerce2 site he gets refused, saying he has not enough permissions.
Logging into ecommerce works just fine.

Am I supposed to copy the entire applications/ecommerce directory? What am
I missing? I found this link
http://ofbizwiki.go-integral.com/Wiki.jsp?page=SSSMultiStores1
but if there is any other good documentation on this out there I'd greatly
appriciate it.

I'm using opentabs-0.9.2.


Thank you,

--Kurt


Mime
View raw message