ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From BJ Freeman <bjf...@free-man.net>
Subject Re: multiple websites configuration
Date Thu, 05 Oct 2006 06:15:18 GMT
You title seems to refer to multiple domain websites
if you are attempting that, then the approach you are using is not correct.
if you are attempting to created many ecommerce sites under one domain, 
then the approach you are describing is somewhat the right direction.

Have you read the OFBizBasicProductionSetup.pdf ?

Kurt T Stam sent the following on 10/4/2006 5:08 PM:
> No one out there that uses multiple websites? All I need to know is from
> where I'm supposed to clone ecommerce: the entire ecommerce application
> or just the ecommerce webapp. I'll figure out from there why I'm having
> this authentication problem.
> 
> Thx,
> 
> --Kurt
> 
> 
> Kurt T Stam wrote:
>> Hi guys,
>>
>> I'm a little confused how to set up multiple websites on ofbiz. Under
>> applications I see the ecommerce directory. In it I see a webapp
>> directory. It contains the ecommerce webapp. I copied this directory and
>> called is webapp2. Then I modified the ofbiz-component.xml to read:
>>
>>   <webapp name="ecommerce"
>>         title="ECommerce"
>>         server="default-server"
>>         location="webapp/ecommerce"
>>         mount-point="/ecommerce"
>>         app-bar-display="false">
>>  <virtual-host host-name="admin.mydomain.com"/>
>>      </webapp>
>>   <webapp name="ecommerce2"
>>         title="ECommerce2"
>>         server="default-server"
>>         location="webapp/ecommerce2"
>>         mount-point="/"
>>         app-bar-display="false">
>>  <virtual-host host-name="www.mydomain.com"/>
>>      </webapp>
>>
>> And I modified the web.xml of ecommerce2 to contain the unique id values
>> of the new website.
>>
>> It all seems to work ok, except when a user wants to log into the
>> ecommerce2 site he gets refused, saying he has not enough permissions.
>> Logging into ecommerce works just fine.
>>
>> Am I supposed to copy the entire applications/ecommerce directory? What am
>> I missing? I found this link
>> http://ofbizwiki.go-integral.com/Wiki.jsp?page=SSSMultiStores1
>> but if there is any other good documentation on this out there I'd greatly
>> appriciate it.
>>
>> I'm using opentabs-0.9.2.
>>
>>
>> Thank you,
>>
>> --Kurt
>>   
> 
> 

Mime
View raw message