ofbiz-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mathieu Lirzin (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (OFBIZ-10695) Improve Gradle code
Date Sat, 20 Jul 2019 18:55:00 GMT

     [ https://issues.apache.org/jira/browse/OFBIZ-10695?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mathieu Lirzin closed OFBIZ-10695.
----------------------------------

> Improve Gradle code
> -------------------
>
>                 Key: OFBIZ-10695
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-10695
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: framework
>    Affects Versions: Trunk
>            Reporter: Mathieu Lirzin
>            Assignee: Mathieu Lirzin
>            Priority: Minor
>             Fix For: Upcoming Branch
>
>         Attachments: OFBIZ-10695_0001-Use-anyMatch-in-subprojectExists.patch, OFBIZ-10695_0002-Replace-iterateOverActiveComponents-with-activeCompo.patch,
OFBIZ-10695_0003-Rewrite-getDirectoryInActiveComponentsIfExists.patch, OFBIZ-10695_0004-Rewrite-installAllPlugins.patch,
OFBIZ-10695_0005-Use-findAll-in-installPlugin-and-generatePluginDocum.patch
>
>
> It would be nice to improve readability to use a more declarative style in Gradle code. 
Moreover the use of Stream avoids the use of callback based methods like what is done in {{iterateOverActiveComponents}}.



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

Mime
View raw message