ofbiz-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Brohl (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OFBIZ-10026) Update build.gradle to the latest dependencies
Date Sat, 02 Dec 2017 17:34:00 GMT

    [ https://issues.apache.org/jira/browse/OFBIZ-10026?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16275668#comment-16275668
] 

Michael Brohl commented on OFBIZ-10026:
---------------------------------------

2nd pass:

The following dependencies have later release versions:
 - org.apache.ant:ant-junit [1.9.7 -> 1.10.1]
 - org.apache.axis2:axis2-kernel [1.7.6 -> 1.7.7]
 - org.apache.axis2:axis2-transport-http [1.7.1 -> 1.7.7]
 - org.apache.axis2:axis2-transport-local [1.7.1 -> 1.7.7]
 - com.github.ben-manes:gradle-versions-plugin [0.15.0 -> 0.17.0]
 - org.apache.httpcomponents:httpclient-cache [4.5.3 -> 4.5.4]
 - com.lowagie:itext [4.2.0 -> 4.2.2]
 - javax.servlet.jsp:javax.servlet.jsp-api [2.3.0 -> 2.3.2-b02]
 - org.apache.tomcat:tomcat-catalina [8.5.24 -> 9.0.2]
 - org.apache.tomcat:tomcat-catalina-ha [8.5.24 -> 9.0.1]
 - org.apache.tomcat:tomcat-jasper [8.5.24 -> 9.0.2]
 - org.apache.tomcat:tomcat-tribes [8.5.24 -> 9.0.1]

> Update build.gradle to the latest dependencies
> ----------------------------------------------
>
>                 Key: OFBIZ-10026
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-10026
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: framework
>    Affects Versions: Trunk
>            Reporter: Michael Brohl
>            Assignee: Michael Brohl
>            Priority: Minor
>
> The following dependencies have later release versions:
>  - org.apache.ant:ant-junit [1.9.7 -> 1.10.1]
>  - org.apache.axis2:axis2-transport-http [1.7.1 -> 1.7.6]
>  - org.apache.axis2:axis2-transport-local [1.7.1 -> 1.7.6]
>  - commons-cli:commons-cli [1.3.1 -> 1.4]
>  - commons-net:commons-net [3.3 -> 3.6]
>  - commons-validator:commons-validator [1.5.1 -> 1.6]
>  - com.google.zxing:core [3.3.0 -> 3.3.1]
>  - org.freemarker:freemarker [2.3.26-incubating -> 2.3.27-incubating]
>  - com.github.ben-manes:gradle-versions-plugin [0.15.0 -> 0.17.0]
>  - org.codehaus.groovy:groovy-all [2.4.12 -> 2.4.13]
>  - com.ibm.icu:icu4j [59.1 -> 60.1]
>  - com.lowagie:itext [4.2.0 -> 4.2.2]
>  - javax.servlet.jsp:javax.servlet.jsp-api [2.3.0 -> 2.3.2-b02]
>  - com.googlecode.libphonenumber:libphonenumber [8.8.3 -> 8.8.7]
>  - org.apache.logging.log4j:log4j-1.2-api [2.9.1 -> 2.10.0]
>  - org.apache.logging.log4j:log4j-api [2.9.1 -> 2.10.0]
>  - org.apache.logging.log4j:log4j-core [2.9.1 -> 2.10.0]
>  - org.apache.logging.log4j:log4j-jul [2.9.1 -> 2.10.0]
>  - org.apache.logging.log4j:log4j-slf4j-impl [2.9.1 -> 2.10.0]
>  - org.springframework:spring-test [4.2.3.RELEASE -> 5.0.2.RELEASE]
>  - org.apache.tomcat:tomcat-catalina [8.5.23 -> 9.0.1]
>  - org.apache.tomcat:tomcat-catalina-ha [8.5.23 -> 9.0.1]
>  - org.apache.tomcat:tomcat-jasper [8.5.23 -> 9.0.1]
>  - org.apache.tomcat:tomcat-tribes [8.5.23 -> 9.0.1]
> In preparation of the upcoming release, we should try to update the dependencies.
> Last time I skipped the Tomcat upgrade, should we try to upgrade this too?
> What do people think?



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message