ofbiz-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aman Agrawal (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (OFBIZ-9696) Fix type entities to follow convention of hasTable
Date Sat, 23 Sep 2017 06:30:01 GMT

    [ https://issues.apache.org/jira/browse/OFBIZ-9696?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16177594#comment-16177594
] 

Aman Agrawal edited comment on OFBIZ-9696 at 9/23/17 6:29 AM:
--------------------------------------------------------------

Patch available for PaymentGatewayConfigType entity.
In this changed the type field like:
"SAGEPAY" -> "PAY_GATWY_SAGEPAY"
and made changes in PaymentGatewayConfig entity.
Also made changes in the code base.


was (Author: aman.agrawal):
Patch available for PaymentGatewayConfigType entity.
In this changed the type field like:
"SAGEPAY" -> "PAY_GATWY_SAGEPAY"
and also made changes in PaymentGatewayConfig entity.

> Fix type entities to follow convention of hasTable
> --------------------------------------------------
>
>                 Key: OFBIZ-9696
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-9696
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: ALL COMPONENTS
>    Affects Versions: Trunk
>            Reporter: Arun Patidar
>            Assignee: Arun Patidar
>         Attachments: OFBIZ-9696-2.patch, OFBIZ-9696.patch
>
>
> 'hasTable' field of 'Type' entities is used to give an idea that detail entity exists
or not. We generally get the name of detail entity on the basis of typeId field value. 
> For example : 
> ContactMechType,contactMechTypeId = "POSTAL_ADDRESS"  then we go to PostalAddress for
detail.
> similarly,
> ContactMechType,contactMechTypeId = "TELECOM_NUMBER"  then we go to TelecomNumber for
detail.
> We should follow the naming convention.
> Below are some entities that are not following the pattern. Some of them are:
>    - ShipmentGatewayConfigType
>    - PaymentGatewayConfigType



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message