ofbiz-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacques Le Roux (JIRA)" <j...@apache.org>
Subject [jira] [Created] (OFBIZ-9449) Missing secure port when sending mails
Date Thu, 06 Jul 2017 19:00:00 GMT
Jacques Le Roux created OFBIZ-9449:
--------------------------------------

             Summary: Missing secure port when sending mails
                 Key: OFBIZ-9449
                 URL: https://issues.apache.org/jira/browse/OFBIZ-9449
             Project: OFBiz
          Issue Type: Bug
          Components: framework
    Affects Versions: Release Branch 16.11, Trunk
            Reporter: Jacques Le Roux
            Assignee: Jacques Le Roux
             Fix For: 16.11.04


While working on an issue reported by Pierre Gaudin on user ML https://s.apache.org/gDo3,
here quoted:
{quote}
While testing the sending of a new password on a local trunk, I meet an error.
Here are the stapes to reproduce:
 - ont the login page click on 'Forgot Your Password?'
 - an email is sent with a link
 - click the link
 - a form is display allowing to indicate the new password
 - clik on submit button and then an error message is display

In the local OFBiz log i can see this errror message :
{code}
> Unable to execute 'doFinal' with cipher instance [javax.crypto.Cipher@42f40da].
{code}

If i do the same on on trunk demo i see this error message :
{code}
> org.apache.ofbiz.entity.EntityCryptoException: org.apache.ofbiz.entity.EntityCryptoException:
key(Secret Key) not found in database (key(Secret Key) not found in database)
> at org.apache.ofbiz.entity.util.EntityCrypto.decrypt(EntityCrypto.java:138) ~[ofbiz.jar:?]
> at org.apache.ofbiz.webapp.control.LoginWorker.login(LoginWorker.java:336) [ofbiz.jar:?]
{code}
{quote}

I found another issue while testing: the port 8443 is missing  in the URL used underneath
by the form reported by Pierre.

It was broken by OFBIZ-9206 where I removed the value of port.https in url.properties. It's
not an issue if you set the value of port.https, or let it empty when using a SSL certificate
on a production server. But if you try locally (localhost) then the URL misses the 8443 port.




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message