ofbiz-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Taher Alkhateeb (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (OFBIZ-9392) Refactor CatalinaContainer
Date Thu, 08 Jun 2017 12:34:18 GMT

     [ https://issues.apache.org/jira/browse/OFBIZ-9392?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Taher Alkhateeb updated OFBIZ-9392:
-----------------------------------
    Attachment: OFBIZ-9392.patch

Attaching a patch for refactoring the CatalinaContainer

No functional change, but an almost complete rewrite of the tomcat container
with the following highlights:

- breakup the logic in init() many smaller functions each specializing in one
  thing
- Unify the host creation logic between main host and context-specific hosts
- introduce streams and lambdas where appropriate
- rename loadComponents() to loadWebapps()
- rename createContext() to createCallableContext()
- rename configureContext() to prepareContext()
- remove instance variables that are not necessary / redundant for operating
  the container correctly and refactor the code logic accordingly
- remove unnecessary valve comments and point to documentation URL
- remove any commented out code
- remove the static block for initializing SSLUtil.loadJsseProperties(). This
  code is already called and hence redundant
- remove redundant / dead / unused code
- add missing FilterDef to context
- lots and lots of re-arranging and small code improvements


> Refactor CatalinaContainer
> --------------------------
>
>                 Key: OFBIZ-9392
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-9392
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: framework
>            Reporter: Taher Alkhateeb
>            Assignee: Taher Alkhateeb
>            Priority: Minor
>         Attachments: OFBIZ-9392.patch
>
>
> The implementation of CatalinaContainer.java is currently very verbose, has replicated
code, and is difficult to navigate.
> The objective of this JIRA is to breakup the logic into smaller manageable functions
to allow for further enhancements in the future.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message