ofbiz-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Coric (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OFBIZ-9373) create new blog article entry error.
Date Sat, 17 Jun 2017 16:12:01 GMT

    [ https://issues.apache.org/jira/browse/OFBIZ-9373?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16052897#comment-16052897
] 

Daniel Coric commented on OFBIZ-9373:
-------------------------------------

Hello Yao and Jacques,

I just changed from mode="INOUT" to mode="IN" (Line: 107) in the "/ofbiz-16.11/applications/content/servicedef/services_data.xml"
and rebuilt the project - as far as I can see everything works as expected. 

We can find the same line in the release15.12 "/ofbiz-15.12/applications/content/servicedef/services_data.xml"
(Line: 108) and there everything works as expected.

I must admit, I don't understand this change.

> create new blog article entry error.
> ------------------------------------
>
>                 Key: OFBIZ-9373
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-9373
>             Project: OFBiz
>          Issue Type: Bug
>          Components: content
>    Affects Versions: Trunk
>            Reporter: yao
>            Assignee: Jacques Le Roux
>
> 1、when i try to create a new blog article, i get the following error message:
>               In field [articleData] less-than (<) and greater-than (>) symbols
are not allowed.
> it seems that this field does not support html text !
> 2、after i use plain text for the field [articleData], when i post the form, i get the
following error message:
>                 The following required parameter is missing: [IN] [createElectronicText.dataResourceId]]
> and i go through the code that handles the request and the log record, to find that the
following eca does not execute which causes the error:
>              
> <!-- electronic text; needs dataResourceId -->
>     <eca service="createElectronicText" event="invoke">
>         <condition field-name="dataResourceId" operator="is-empty"/>
>         <set field-name="dataResourceTypeId" value="ELECTRONIC_TEXT"/>
>         <action service="createDataResource" mode="sync" result-to-context="true"/>
>     </eca>
> does the problem lies in the framework code ?



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message