ofbiz-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "yao (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OFBIZ-9373) create new blog article entry error.
Date Thu, 15 Jun 2017 08:11:00 GMT

    [ https://issues.apache.org/jira/browse/OFBIZ-9373?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16050131#comment-16050131
] 

yao commented on OFBIZ-9373:
----------------------------

Hi Jacques and Daniel,

I have just solved this problem. In [createElectronicText] eca we use the event "invoke",
but the validating event happens before invoking , there lies the problem. The validation
can't pass!

so to solve it , I just set the event type to "in-validate". But After that , i get another
problem. the error message is : [Unknown parameter found:dataResource]. After some reviewing
of the code , i see that there's no attribute name "dataResource" in the service definition.
Just add one and make it optional .

I don't know if my solution is appropriate. 

> create new blog article entry error.
> ------------------------------------
>
>                 Key: OFBIZ-9373
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-9373
>             Project: OFBiz
>          Issue Type: Bug
>          Components: content
>    Affects Versions: Trunk
>            Reporter: yao
>            Assignee: Jacques Le Roux
>
> 1、when i try to create a new blog article, i get the following error message:
>               In field [articleData] less-than (<) and greater-than (>) symbols
are not allowed.
> it seems that this field does not support html text !
> 2、after i use plain text for the field [articleData], when i post the form, i get the
following error message:
>                 The following required parameter is missing: [IN] [createElectronicText.dataResourceId]]
> and i go through the code that handles the request and the log record, to find that the
following eca does not execute which causes the error:
>              
> <!-- electronic text; needs dataResourceId -->
>     <eca service="createElectronicText" event="invoke">
>         <condition field-name="dataResourceId" operator="is-empty"/>
>         <set field-name="dataResourceTypeId" value="ELECTRONIC_TEXT"/>
>         <action service="createDataResource" mode="sync" result-to-context="true"/>
>     </eca>
> does the problem lies in the framework code ?



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message