ofbiz-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre Smits (JIRA)" <j...@apache.org>
Subject [jira] [Created] (OFBIZ-9141) Refactor 'default-map-name' and 'list-name' into one mapping definition for form widgets.
Date Sat, 10 Dec 2016 09:43:58 GMT
Pierre Smits created OFBIZ-9141:
-----------------------------------

             Summary: Refactor 'default-map-name' and 'list-name' into one mapping definition
for form widgets.
                 Key: OFBIZ-9141
                 URL: https://issues.apache.org/jira/browse/OFBIZ-9141
             Project: OFBiz
          Issue Type: Improvement
          Components: ALL COMPONENTS, framework
    Affects Versions: Trunk
            Reporter: Pierre Smits


Currently we have:
* 'default-map-name', which can applied to form definitions of type='single'
* 'list-name', which can be applied to form definitions of type='list' and type="multi and
to grid definitions 

They both mean the same, and it is the parent definition that defines how the mapped data
is rendered. 

Refactoring into one definition reduces the footprint, and removes ambiguity.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message