ofbiz-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacques Le Roux (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (OFBIZ-6905) Update Xalan libs to version 2.7.2 because of CVE-2014-0107
Date Sat, 17 Dec 2016 09:26:58 GMT

     [ https://issues.apache.org/jira/browse/OFBIZ-6905?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jacques Le Roux updated OFBIZ-6905:
-----------------------------------
    Labels: CVE  (was: )

> Update Xalan libs to version 2.7.2 because of CVE-2014-0107
> -----------------------------------------------------------
>
>                 Key: OFBIZ-6905
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-6905
>             Project: OFBiz
>          Issue Type: Sub-task
>          Components: framework, specialpurpose/cmssite
>    Affects Versions: Release Branch 12.04, Release Branch 13.07, Release Branch 14.12,
Trunk, Release Branch 15.12
>            Reporter: Jacques Le Roux
>            Assignee: Jacques Le Roux
>              Labels: CVE
>             Fix For: 14.12.01, 12.04.06, 13.07.03, 16.11.01
>
>
> Quoting https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-0107 which was fixed
by XALANJ-2435
> {quote}
> The TransformerFactory in Apache Xalan-Java before 2.7.2 does not properly restrict access
to certain properties when FEATURE_SECURE_PROCESSING is enabled, which allows remote attackers
to bypass expected restrictions and load arbitrary classes or access external resources via
a crafted (1) xalan:content-header, (2) xalan:entities, (3) xslt:content-header, or (4) xslt:entities
property, or a Java property that is bound to the XSLT 1.0 system-property function.
> {quote}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message