ofbiz-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Taher Alkhateeb (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OFBIZ-8337) Refactor and simplify the startup sequence in OFBiz
Date Wed, 28 Sep 2016 09:45:20 GMT

    [ https://issues.apache.org/jira/browse/OFBIZ-8337?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15529091#comment-15529091
] 

Taher Alkhateeb commented on OFBIZ-8337:
----------------------------------------

Thank you, very kind of you Ashish :) I will submit a patch (I'm still in the middle of the
pain) and I would really appreciate help and feedback if you have time.

> Refactor and simplify the startup sequence in OFBiz
> ---------------------------------------------------
>
>                 Key: OFBIZ-8337
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-8337
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: base, start
>    Affects Versions: Upcoming Branch
>            Reporter: Taher Alkhateeb
>            Assignee: Taher Alkhateeb
>            Priority: Minor
>
> The startup sequence in OFBiz is highly complex and requires improvements on multiple
levels including:
> - The entire classpath buildup logic and org.apache.ofbiz.base.start.Classpath needs
to be removed. The original idea of classpath isolation between the components created many
more problems than it solved, and right now the classpath construction is the responsibility
of the build system.
> - The custom classloader needs to be removed as well together with the classpath mentioned
above.
> - The StartupLoader interface should remove the start() method and just have two methods,
load and unload.
> - The startup sequence should have only one StartupLoader, not an array of startup loaders.
This StartupLoader (implemented as ContainerLoader) is the only class responsible for bootstrapping
OFBiz
> - The ContainerLoader needs to be completely refactored, not only to remove the start()
method but also to cleanup the very messy logic currently residing there.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message