ofbiz-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Brohl (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (OFBIZ-6300) Compiler-Error with JDK 1.8 and source compatibility 1.8
Date Mon, 19 Sep 2016 11:41:20 GMT

     [ https://issues.apache.org/jira/browse/OFBIZ-6300?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael Brohl reopened OFBIZ-6300:
----------------------------------

Reopened to check the request from [~tomas.pytelka] to backport to 14.12. I will have a look
at it.

> Compiler-Error with JDK 1.8 and source compatibility 1.8
> --------------------------------------------------------
>
>                 Key: OFBIZ-6300
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-6300
>             Project: OFBiz
>          Issue Type: Bug
>          Components: framework
>    Affects Versions: Trunk
>            Reporter: Martin Becker
>            Assignee: Michael Brohl
>             Fix For: 15.12.01
>
>         Attachments: OFBIZ-6300-EntityFieldMap.patch
>
>
> I just found another error compiling the code with JDK 1.8 with source code compatibility
switched to 1.8 in my eclipse workspace. The external ant build is working because there is
java version 1.7 defined as target in the macros.xml.
> The error is an issue regarding generics in EntityFieldMap.java.
> I will provide a patch her soon.
> The code is the same in the release branches.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message