ofbiz-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacques Le Roux <jacques.le.r...@les7arts.com>
Subject Re: buildbot failure in on ofbiz-trunk-framework-plugins
Date Sun, 17 Dec 2017 12:18:04 GMT
Hi Taher,

I did not find something specific.

The message I try to convey is this is an external random condition, not related to Buildbot
or our script but the network+servers context.

 From time to time (more often since the date I put in the Infra Jira, but I can't see a relation
with changes then in our script and it was happening 
before also) the tests fail and when I manually restart the same build they pass.

So for me it's not due to our script, which is only starting the tests, but to another conditions(/s?)
on the network+servers context. Note that we 
use 3 test servers.

Note also that it happens that the "svn up"' phase fails. I once asked Gavin and he the told
me that in such case I simply have to manually restart 
the tests...

That's when I learnt how to do it and that's what, among other things but mostly, I want to
document

Thanks to care!

Jacques


Le 17/12/2017 à 12:37, Taher Alkhateeb a écrit :
> Hi Jacques, I still don't understand how you determined that it is
> _not_ a buildbot scripting issue? I need that information in order to
> isolate the cause of these annoying error messages. I find it unlikely
> to be a genuine bug in buildbot and more likely a bug in our scripts.
> So perhaps you can share what you found so that I focus my efforts in
> the right place?
>
> On Wed, Dec 13, 2017 at 9:07 PM, Jacques Le Roux
> <jacques.le.roux@les7arts.com> wrote:
>> Taher,
>>
>> Look at
>> https://ci.apache.org/builders/ofbiz-trunk-framework-plugins?numbuilds=150
>>
>>  From time to time, when I find weird that a build fails on Buildbot but not
>> locally, I force a build on Buildbot manually (ie redo an existing commit)
>> and then it passes
>> Eg:
>> Dec 05 06:47
>>
>>          1817154         success         #797
>> <https://ci.apache.org/builders/ofbiz-trunk-framework-plugins/builds/797>
>> forced: by IRC user <jleroux> (privmsg): forces manual build after tests
>> errors         Build successful
>> Dec 05 04:16    1817151         failure         #796
>> <https://ci.apache.org/builders/ofbiz-trunk-framework-plugins/builds/796>
>> The AnyBranchScheduler scheduler named 'on-ofbiz-framework-commit' triggered
>> this build         Failed shell_4
>>
>>
>> Dec 08 19:40
>>
>>          1817550         success         #805
>> <https://ci.apache.org/builders/ofbiz-trunk-framework-plugins/builds/805>
>> The AnyBranchScheduler scheduler named 'on-ofbiz-framework-commit' triggered
>> this build         Build successful
>> Dec 08 10:14    1817479         success         #804
>> <https://ci.apache.org/builders/ofbiz-trunk-framework-plugins/builds/804>
>> forced: by IRC user <jleroux> (privmsg): forces manual build after BuilBot
>> signaling a failure (OK locally)     Build successful
>>
>>
>> Of course you can check there are no OFBiz commits between these forcings.
>> Remember we share SVN and Buildbot with other TLPs...
>>
>> At contratrio, this one was a real issue I wanted to be sure about, see it
>> fails 2 times...
>> Dec 13 10:23
>>
>>          1817994         failure         #869
>> <https://ci.apache.org/builders/ofbiz-trunk-framework-plugins/builds/869>
>> forced: by IRC user <jleroux> (privmsg): forces manual build to check we
>> have a real error with testPerformFind         Failed shell_4
>> Dec 13 09:23    1817989         failure         #868
>> <https://ci.apache.org/builders/ofbiz-trunk-framework-plugins/builds/868>
>> The AnyBranchScheduler scheduler named 'on-ofbiz-framework-commit' triggered
>> this build         Failed shell_4
>>
>>
>> You can find the same on
>> https://ci.apache.org/builders/ofbiz-trunk-framework?numbuilds=150
>>
>> BTW this was a good question and I'll add this info in the infra request.
>>
>> I tend to forgot about how I do things. I'm really the kind of intuitive
>> people. But I can help myself when I need to help others :)
>>
>> Jacques
>>
>>
>> Le 13/12/2017 à 17:12, Taher Alkhateeb a écrit :
>>> How did you determine it's not the buildbot script?
>>>
>>> On Wed, Dec 13, 2017 at 7:05 PM, Jacques Le Roux
>>> <jacques.le.roux@les7arts.com> wrote:
>>>> I fear it's not part of our BuildBot config, so I asked help from infra.
>>>> Maybe this can help
>>>>
>>>> https://issues.apache.org/jira/servicedesk/customer/portal/1/INFRA-15394
>>>>
>>>> Jacques
>>>>
>>>>
>>>>
>>>> Le 13/12/2017 à 16:21, Taher Alkhateeb a écrit :
>>>>> These error messages are becoming excessive and indicating a faulty
>>>>> buildbot implementation. I would like to work on it. Is anyone
>>>>> interested in helping me or has background information that might
>>>>> help?
>>>>>
>>>>> On Wed, Dec 13, 2017 at 5:36 PM,  <buildbot@apache.org> wrote:
>>>>>> The Buildbot has detected a new failure on builder
>>>>>> ofbiz-trunk-framework-plugins while building . Full details are
>>>>>> available
>>>>>> at:
>>>>>>
>>>>>> https://ci.apache.org/builders/ofbiz-trunk-framework-plugins/builds/877
>>>>>>
>>>>>> Buildbot URL: https://ci.apache.org/
>>>>>>
>>>>>> Buildslave for this Build: silvanus_ubuntu
>>>>>>
>>>>>> Build Reason: The AnyBranchScheduler scheduler named
>>>>>> 'on-ofbiz-framework-commit' triggered this build
>>>>>> Build Source Stamp: [branch ofbiz/ofbiz-framework/trunk] 1818020
>>>>>> Blamelist: jleroux
>>>>>>
>>>>>> BUILD FAILED: failed shell_4
>>>>>>
>>>>>> Sincerely,
>>>>>>     -The Buildbot
>>>>>>
>>>>>>
>>>>>>


Mime
View raw message