ofbiz-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Montalbano Florian (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OFBIZ-7657) Use 'conditionFields' in LookupContact
Date Tue, 28 Jun 2016 09:33:57 GMT

    [ https://issues.apache.org/jira/browse/OFBIZ-7657?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15352671#comment-15352671
] 

Montalbano Florian commented on OFBIZ-7657:
-------------------------------------------

Hi [~deepakddixit],
you are right, both are doing the same thing. I asked in OFBIZ-7576 if there was a difference
and [~jacques.le.roux] said it was just epsilon difference in performance but easier to read.
That's why, I'm changing the 'andCondition' to 'conditionFields'.

I read your other comment and if there is no need to declare the 'conditionFields' as a map
then it's even better !

Is that ok for you ?

> Use 'conditionFields' in LookupContact
> --------------------------------------
>
>                 Key: OFBIZ-7657
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-7657
>             Project: OFBiz
>          Issue Type: Sub-task
>          Components: party
>    Affects Versions: Trunk
>            Reporter: Montalbano Florian
>            Priority: Minor
>              Labels: andCondition, autocomplete, conditionFields, lookup
>         Attachments: OFBIZ-7657.patch
>
>
> Change 'andCondition' (which uses direct groovy call) to 'conditionFields' in the lookup
LookupScreens#LookupContact.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message