ofbiz-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "james yong (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OFBIZ-6755) Update the passport component to use httpclient/core-4.4.1 instead of commons-httpclient-3.1
Date Mon, 28 Mar 2016 13:49:25 GMT

    [ https://issues.apache.org/jira/browse/OFBIZ-6755?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15214213#comment-15214213
] 

james yong commented on OFBIZ-6755:
-----------------------------------

There is no commons-httpclient-3.1.jar in the project but the .classpath file still links
to it
{quote}
<classpathentry kind="lib" path="specialpurpose/passport/lib/commons-httpclient-3.1.jar"/>
{quote}

> Update the passport component to use httpclient/core-4.4.1 instead of commons-httpclient-3.1
> --------------------------------------------------------------------------------------------
>
>                 Key: OFBIZ-6755
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-6755
>             Project: OFBiz
>          Issue Type: Sub-task
>          Components: specialpurpose/passport
>    Affects Versions: Trunk
>            Reporter: Jacques Le Roux
>            Assignee: Shi Jinghai
>             Fix For: Upcoming Branch
>
>
> The passport component uses commons-httpclient-3.1. This librairies is not only deprecated
but also faces a number of vulnerabilties:
> https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2015-5262
> https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-3577
> https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2012-6153
> The solution is to update to httpclient/core-4.4.1 that we have already in base/lib



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message