ofbiz-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Badenhorst (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OFBIZ-6658) Creating a new tenant fails
Date Wed, 30 Sep 2015 14:40:04 GMT

    [ https://issues.apache.org/jira/browse/OFBIZ-6658?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14936909#comment-14936909
] 

Stefan Badenhorst commented on OFBIZ-6658:
------------------------------------------

I could not find the file you refereced, but I did find this one in the same path: PasswordSecurityData.xml
This is the contents:
{code}
<?xml version="1.0" encoding="UTF-8"?>
<!--
Licensed to the Apache Software Foundation (ASF) under one
or more contributor license agreements.  See the NOTICE file
distributed with this work for additional information
regarding copyright ownership.  The ASF licenses this file
to you under the Apache License, Version 2.0 (the
"License"); you may not use this file except in compliance
with the License.  You may obtain a copy of the License at

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing,
software distributed under the License is distributed on an
"AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
KIND, either express or implied.  See the License for the
specific language governing permissions and limitations
under the License.
-->

<entity-engine-xml>
    <!-- from the securityext component: SecurityExtData.xml -->
    <UserLogin userLoginId="admin" currentPassword="{SHA}47b56994cbc2b6d10aa1be30f70165adb305a41a"
passwordHint=""/>
    <UserLogin userLoginId="flexadmin" currentPassword="{SHA}47b56994cbc2b6d10aa1be30f70165adb305a41a"
passwordHint=""/>
    <UserLogin userLoginId="demoadmin" currentPassword="{SHA}47b56994cbc2b6d10aa1be30f70165adb305a41a"
passwordHint=""/>
    <UserLogin userLoginId="ltdadmin" currentPassword="{SHA}47b56994cbc2b6d10aa1be30f70165adb305a41a"
passwordHint=""/>
    <UserLogin userLoginId="ltdadmin1" currentPassword="{SHA}47b56994cbc2b6d10aa1be30f70165adb305a41a"
passwordHint=""/>
    <UserLogin userLoginId="bizadmin" currentPassword="{SHA}47b56994cbc2b6d10aa1be30f70165adb305a41a"
passwordHint=""/>
</entity-engine-xml>

{code}

I pasted the XML into 'Complete XML document' input and clicked 'Import Text'
Than got this response:
Results:
Got 6 entities to write to the datasource.

Then I ran the ant create-tenant command again, but I have the same issue.

> Creating a new tenant fails
> ---------------------------
>
>                 Key: OFBIZ-6658
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-6658
>             Project: OFBiz
>          Issue Type: Bug
>          Components: ALL APPLICATIONS
>    Affects Versions: 13.07.02
>         Environment: Windows
>            Reporter: Stefan Badenhorst
>            Assignee: Pierre Smits
>         Attachments: log files.7z
>
>
> When setting up an additional tenant. I'm having trouble logging in as the administrator.

> I have downloaded OfBiz 13.07.02 and changed the configuration to connect to Postgres
9.4.  Now I have it working with the demo data loaded. I want to add a new tenant with no
demo data loaded.  I heave read many articles and tried the suggestions, the furthest I have
gotten is to run this at the command line:  ant create-tenant  At first I got errors using
this and I realized that it could not create the databases that I was specifying. I manually
created the databases with my chosen tenant id '10001'. So now I have 2 additional databases
ofbiz_10001 and ofbizolap_10001.  At the point where it asks me what data to install I have
tried both 'Seed' and 'seed-initial'. I must confess that I'm not sure what this means.  I
ran the create-tenant again and this time it created 833 tables in the main database and 6
tables in the olap database.  At the end it tells me the following: [echo] Delegator = default#10001
[echo] Tenant admin = '10001-admin' [echo] Password for tenant admin is 'ofbiz' must change
on first login  I have also update the global config to show the tenant input on the login
screen.  When I try to login with the above user, it tells me that the user does not exist.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message