ofbiz-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carsten Schinzer <c.schin...@gmail.com>
Subject Re: [jira] [Updated] (OFBIZ-5019) Multitenant delegator assignment not working correctly
Date Tue, 18 Sep 2012 14:20:32 GMT
Hello Dale,


I am now confused. Does  this work for you or not?
The patch fix runs fine with my dev and my production environment.

I have to admit, I did not follow the procedure that you mention.

I did simply exchange the two class files, recompile and restart my system.

If you feel I should do more before committing the patch, please let me
know.
As I am currently moving houses, my dev environment unforrtunately is
powered down and deep down in one of the boxes ;-/

Kind regards


Carsten

2012/9/18 Dale E. Moore (JIRA) <jira@apache.org>

>
>      [
> https://issues.apache.org/jira/browse/OFBIZ-5019?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel]
>
> Dale E. Moore updated OFBIZ-5019:
> ---------------------------------
>
>     Comment: was deleted
>
> (was: Please pardon my ignorance Carsten, but; I would like to try your
> patch and see if I'm able to start using ofBiz multitenant and wonder if
> I'm proceeding properly. Here is what I've done:
>
>
> svn co https://svn.apache.org/repos/asf/ofbiz/trunk ofbiz.trunk
> cd ofbiz.trunk
> ./ant load-demo-multitenant
> vi framework/common/config/general.properties
> Change multitenant to Y
> Download patch from
> https://issues.apache.org/jira/browse/OFBIZ-5019?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanelto
parent folder.
> patch -p0 <
> ../OFBIZ-5019_Multitenant_delegator_assignment_not_working_correctly.patch
> ./ant load-tenant-admin-user-login -DdelegatorId=DEMO1
> -DuserLoginId=adminDemo
> ./ant load-tenant-admin-user-login -DdelegatorId=DEMO2
> -DuserLoginId=adminDemo
> ./ant start
>
>
> Here are the results from my attempt to start ofBiz:
>
>
> Buildfile: /home/dalem/workspace/ofbiz.trunk/build.xml
>
> start:
>      [java] Start.java using configuration file
> org/ofbiz/base/start/start.properties
>      [java] Set OFBIZ_HOME to - /home/dalem/workspace/ofbiz.trunk
>      [java] Exception in thread "main"
> org.ofbiz.base.start.StartupException: Couldn't create server socket(/
> 127.0.0.1:10523)
>      [java]     at
> org.ofbiz.base.start.Start$AdminPortThread.<init>(Start.java:387)
>      [java]     at
> org.ofbiz.base.start.Start.createListenerThread(Start.java:140)
>      [java]     at org.ofbiz.base.start.Start.init(Start.java:199)
>      [java]     at org.ofbiz.base.start.Start.main(Start.java:112)
>      [java] Caused by: java.net.BindException: Address already in use
>      [java]     at java.net.PlainSocketImpl.socketBind(Native Method)
>      [java]     at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:383)
>      [java]     at java.net.ServerSocket.bind(ServerSocket.java:328)
>      [java]     at java.net.ServerSocket.<init>(ServerSocket.java:194)
>      [java]     at
> org.ofbiz.base.start.Start$AdminPortThread.<init>(Start.java:385)
>      [java]     ... 3 more
>      [java] Java Result: 1
>
> BUILD SUCCESSFUL
> Total time: 1 second
>
>
> I am suspicious that this is not the result for which you had hoped.
>
> Perhaps I should start from some ofBiz version other than
> https://svn.apache.org/repos/asf/ofbiz/trunk?
>
> Any suggestions you have are very much appreciated,
> DaleEMoore@gMail.Com)
>
> > Multitenant delegator assignment not working  correctly
> > -------------------------------------------------------
> >
> >                 Key: OFBIZ-5019
> >                 URL: https://issues.apache.org/jira/browse/OFBIZ-5019
> >             Project: OFBiz
> >          Issue Type: Bug
> >          Components: ALL APPLICATIONS, framework
> >    Affects Versions: SVN trunk
> >         Environment: multitenantuse = "Y"
> > Tenant with no Domain setting or Tenant using different domain for
> backend applications
> >            Reporter: Carsten Schinzer
> >              Labels: authentication, context, multitenancy, security
> >         Attachments:
> OFBIZ-5019_Multitenant_delegator_assignment_not_working_correctly.patch
> >
> >   Original Estimate: 168h
> >  Remaining Estimate: 168h
> >
> > This issue arises when Multitenancy is in use. It arises only on backend
> applications (as typically the frontend store applications will use a
> context variable defined in web.xml to determin the delegator to be used
> (ie. the database to use for data lookups etc).
> > The issue manifests as follows:
> > * the wrong data is read for standard backoffice displays (e.g. orders,
> accounts, etc.); it is the dataa from the default datasource, not the
> tenant´s data source
> > * in the backend apps certain functions require authentication (checked
> dynamically) and this will fail when the default delegator is used since
> the tenant's user accounts will differ (if not in name then in password
> hashes) from the default datasource -- this leads to authentication
> warnings all over the place
> > * one will not be able to mainpulate data of course, either
>
> --
> This message is automatically generated by JIRA.
> If you think it was sent incorrectly, please contact your JIRA
> administrators
> For more information on JIRA, see: http://www.atlassian.com/software/jira
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message