ofbiz-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Geisert (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OFBIZ-4749) OfBiz 10.04 Does not compile with Oracle JDK 7
Date Fri, 07 Sep 2012 07:37:07 GMT

    [ https://issues.apache.org/jira/browse/OFBIZ-4749?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13450439#comment-13450439
] 

Christian Geisert commented on OFBIZ-4749:
------------------------------------------

This also happens with OpenJDK 6 (see OFBIZ-3993) so I think we should fix it.
                
> OfBiz 10.04 Does not compile with Oracle JDK 7
> ----------------------------------------------
>
>                 Key: OFBIZ-4749
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-4749
>             Project: OFBiz
>          Issue Type: Bug
>    Affects Versions: Release 10.04
>         Environment: Windows 7, Oracle JDK 7
>            Reporter: Karl Laird
>            Priority: Critical
>              Labels: build-failure
>             Fix For: Release 10.04
>
>
> The OFBIZ version is apache-ofbiz-10.04
> When I'm compiling the project with the embedded and using ant run-install run there
is a error message
> classes:
>   [javac16] Compiling 13 source files to C:\_portable\PortableApps\apache-ofbiz-10.04\framework\security\build\classes
>   [javac16] warning: [options] bootstrap class path not set in conjunction with -source
1.6
>   [javac16] C:\_portable\PortableApps\apache-ofbiz-10.04\framework\security\src\org\ofbiz\security\OFBizSecurity.java:52:
error: invalid inferred types for V; inferred type does not conform to declared bound(s)
>   [javac16]     protected static final Map<String, Map<String, String>> simpleRoleEntity
= UtilMisc.toMap(
>   [javac16]                                                                         
                    ^
>   [javac16]     inferred: Map<String,Object>
>   [javac16]     bound(s): Map<String,String>
>   [javac16]   where V,V1,V2,V3 are type-variables:
>   [javac16]     V extends Object declared in method <V,V1,V2,V3>toMap(String,V1,String,V2,String,V3)
>   [javac16]     V1 extends V declared in method <V,V1,V2,V3>toMap(String,V1,String,V2,String,V3)
>   [javac16]     V2 extends V declared in method <V,V1,V2,V3>toMap(String,V1,String,V2,String,V3)
>   [javac16]     V3 extends V declared in method <V,V1,V2,V3>toMap(String,V1,String,V2,String,V3)
>   [javac16] 1 error
>   [javac16] 1 warning
> Changing to use JDK 6 works around this issue - however given that EOL for JDK6 is November
2012 (IE this year, already extended from July) this is not a long term solution.
> Regards
> Karl

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message