ofbiz-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Gray <scott.g...@hotwaxmedia.com>
Subject Re: buildbot failure in ASF Buildbot on ofbiz-trunk
Date Fri, 01 Jan 2010 21:01:39 GMT
On 1/01/2010, at 1:12 PM, David E Jones wrote:

>
> Is there any way to get more details about this?

The stdio links are all we have at the moment

>
> Evidently I'm to blame for a compile failure... but my last commit  
> that involves something to be compiled was on Dec 27 in rev 894047.

It seems a compile failure is reported whenever an ant task fails,  
compile_1 is the run-tests task and based on the stdio output my guess  
is that we've got some accounting tests in there that will only pass  
in 2009 so your only mistake was to be the first to commit something  
this year :-)

I won't have time to look at fixing the tests for a few days at least  
but if anyone else wants to jump on it that would be appreciated.

> Or does the blame list just look at the most recent commit even  
> though the test may have included various commits since the last test?

Correct, buildbot doesn't test every commit but instead just plays  
catchup by grabbing the latest revision if multiple commits have  
occurred during the previous build cycle.  I think the blamelist will  
include everyone who has committed something to the build being  
reported on.

>
> -David
>
>
> On Dec 31, 2009, at 6:39 PM, buildbot@apache.org wrote:
>
>> The Buildbot has detected a new failure of ofbiz-trunk on ASF  
>> Buildbot.
>> Full details are available at:
>> http://ci.apache.org/builders/ofbiz-trunk/builds/2234
>>
>> Buildbot URL: http://ci.apache.org/
>>
>> Buildslave for this Build: isis_ubuntu
>>
>> Build Reason:
>> Build Source Stamp: [branch ofbiz/trunk] 894956
>> Blamelist: jonesde
>>
>> BUILD FAILED: failed compile_1
>>
>> sincerely,
>> -The ASF Buildbot
>>
>


Mime
View raw message