ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "i.adragna-loewen" <i.adragna-loe...@gmx.de>
Subject AW: Building ode/trunk: Eclipse-Problems
Date Thu, 22 Oct 2009 10:59:02 GMT
Thank you Pascal for the fast help!

The most problems are resolved! But there is still something wrong with
the XML format. Now I get this error in some projects:

"XML format error in '.classpath' file of project 'ode-utils': Bad
format : Build Path Problem"
	
It seems that I have to add another lib to the classpath? 
...
Is there a way to build Eclipse project CORRECTLY in the trunk directory
and then import it into Eclipse? ...I mean how to run rake in order to
regenerate XMLBeans schemas, OpenJPA mapping files, JACOB channel
interfaces, etc..., like it is specified in
http://ode.apache.org/eclipse-ide.html???

Thanks in advance
Inna

-----Ursprüngliche Nachricht-----
Von: Pascal Aho [mailto:P.Aho@gmx.net] 
Gesendet: Donnerstag, 22. Oktober 2009 11:42
An: user@ode.apache.org
Betreff: Re: Building ode/trunk: Eclipse-Problems

Hi,

I have the same problem at the beginning. You have to deactivate build
Automatically in Eclipse under the menu Project. You only need to click
on if there was a hack there and this will disappear. 

Important: bevor you import the projects in eclipse you have to
deactivate build automatically (like explain above) und set the
classpath variable correctly. The folder corresponding to ME_REPO is the
folder under C:/Documents and settings/your user name/.m2/repository

Cheers,

Pascal.



-------- Original-Nachricht --------
> Datum: Thu, 22 Oct 2009 11:29:05 +0200
> Von: i.adragna-loewen@gmx.de
> An: user@ode.apache.org
> Betreff: Building ode/trunk: Eclipse-Problems

> Hey,
> 
> I’m building ode/trunk. After installing buildr, ruby, rake I finally
> got the projects in to my Eclipse-workspace. The problem that I’m
> struggling with now is the amount of Errors that  I get from Eclipse
after importing
> the ode-projects. 
> The M2_REPO variable ist set, like it is instructed here:
> http://ode.apache.org/eclipse-ide.html, but can you please tell me
what exactly is meant by
> the instruction: 
> 
> “... You will occasionally need to run "rake" build in order to
> regenerate XMLBeans schemas, OpenJPA mapping files, JACOB channel
interfaces,
> etc...”
> 
> If I run rake in the trunk directory I get the “rake aborted”- failure
> (presumably because of the missing rakefile). Which steps are needed
to
> resolve the Eclipse-Problems?   I found a patch in the issues (
> https://issues.apache.org/jira/browse/BUILDR-300 ),  but I’m not sure
if it has a
> relation to my problem. If so, what do I have to do with this patch? 
> 
> Thanks in advance
> inna
> -- 
> GRATIS für alle GMX-Mitglieder: Die maxdome Movie-FLAT!
> Jetzt freischalten unter http://portal.gmx.net/de/go/maxdome01
> 
> -- 
> Neu: GMX DSL bis 50.000 kBit/s und 200,- Euro Startguthaben!
> http://portal.gmx.net/de/go/dsl02
> 
> -- 
> GRATIS für alle GMX-Mitglieder: Die maxdome Movie-FLAT!
> Jetzt freischalten unter http://portal.gmx.net/de/go/maxdome01

-- 
GRATIS für alle GMX-Mitglieder: Die maxdome Movie-FLAT!
Jetzt freischalten unter http://portal.gmx.net/de/go/maxdome01


Mime
View raw message