ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rich Taylor" <bhamtay...@gmail.com>
Subject Re: Assignment failure for XSD type AnyType
Date Mon, 19 Nov 2007 18:04:43 GMT
Ouch, I hit the wrong sequence of keys in GMail and it sent the
message early....

After looking at it a bit more, I think it still might an
initialization problem but it isn't clear.

Could you send the BPEL variable declarations, as well as the the WSDL
message types and schemas for the variables?

What I started to say in my previous email is that you will likely
need something like the following (the xml is off since we don't have
the full schema).  You would have this in your bpel before the copy
operation you're currently trying to execute.

<bpws:copy>
    <bpws:from>
        <literal>
            <inTask>
                <taskInput/>
            </inTask>
        </literal>
    </bpws:from>
    <bpws:to ><![CDATA[$inTask.root]]></bpws:to
</bpws:copy>

Cheers, Rich

On Nov 19, 2007 9:54 AM, Rich Taylor <bhamtaylor@gmail.com> wrote:
> Without seeing your entire process it's a little tough to say, but I'm
> guessing that $inTask.root is not being intialized.  If you're not
> doing this yet, you need to do something like (you will likely need to
> set the namespaces appropriately in the literal part):
>
> <bpws:copy>
>     <bpws:from>
>
>     </bpws:from>
> <bpws:to ><![CDATA[$inTask.root]]></bpws:to
> >
> </bpws:copy>
>
>
>
>
> On Nov 18, 2007 10:46 PM, Dhananjay Rao <dhananjay.rao@gmail.com> wrote:
> > Hi All,
> >
> > I'm using following assigment statement in my BPEL process
> >
> > <bpws:copy>
> > <bpws:from xmlns:bpws="
> > http://schemas.xmlsoap.org/ws/2004/03/business-process/"><![CDATA[$inPayload.payload/]]></bpws:from
> > >
> > <bpws:to xmlns:bpws="
> > http://schemas.xmlsoap.org/ws/2004/03/business-process/"><![CDATA[$inTask.root/ns0:taskInput]]></bpws:to
> > >
> > </bpws:copy>
> >
> > The variable inPayload is of following type
> >
> > <xsd:element name="createTaskRequest">
> > <xsd:complexType>
> > <xsd:sequence>
> > <xsd:element name="taskMetaData" type="b4p:taskMetaDataType" />
> > <xsd:element name="participantToken" type="xsd:string" />
> > <xsd:element name="taskInput" />
> > </xsd:sequence>
> > </xsd:complexType>
> > </xsd:element>
> >
> > taskInput is AnyType.
> >
> > and variable inTask is of type
> >
> > <element name="input">
> >     <complexType>
> >   <sequence>
> >             <element name="Address_" type="string"/>
> >             <element name="Name_" type="string"/>
> >         </sequence>
> >     </complexType>
> > </element>
> >
> > When i execute this process following error is thrown in the ode console
> >
> >
> > ERROR - GeronimoLog.error(104) | Assignment Fault: {
> > http://docs.oasis-open.org/wsbpel/2.0/process/executable}selectionFailure,lineNo=168,faultExplanation=Noresults
> > for expression: {OXPath10Expression $inTask.root/ns0:taskInput}
> >
> > I'm i doing something wrong here?
> >
> > Thanks in advance.
> >
> > Regards,
> > Dan
> >
>

Mime
View raw message