ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matth...@offthelip.org>
Subject Buildr upgrade (almost)
Date Tue, 10 Jun 2008 18:07:39 GMT
Hi guys,

I've update our Rakefile to use Buildr 1.3.1.1 and it seems to work now.
However there are a few gotchas. The first is that there's a bug in the
XmlBeans task, I fixed it on Buildr so it should be in the next release. In
the meantime you're left with 2 options: install buildr from the trunk or
patch your local 1.3.1.1 installation like so:

--- addon/buildr/xmlbeans.rb    (revision 666223)
+++ addon/buildr/xmlbeans.rb    (working copy)
@@ -78,7 +78,7 @@
         verbose(false) do
           base = generated.to_s
           FileList["#{base}/**/*.{class,xsb,xsd}"].each do |file|
+            target = File.join(compile.target.to_s,
Util.relative_path(file, base))
-            target = File.join(compile.target.to_s,
Util.relative_path(base, file))
             mkpath File.dirname(target) ; cp file, target
           end
         end

For this reason I haven't directly updated the default Rakefile but
committed another one instead and that's only on trunk for now (I'm thinking
we should maybe stick with Buildr 1.2.X for our stable branch). So you'll
need to do:

buildr --buildfile=Rakefile.buildr1.3 clean test (for example)

If after having Buildr 1.3 installed, you still want to use 1.2 for some
reason, just do:

buildr _1.2.10_ clean test

I had to modify a few things here and there to get things to work (mostly
JUnit related) but normally the build should work with either version,
provided that you use the correct Rakefile. Hopefully we'll get the last
issues ironed out little by little until we can have the trunk fully rely on
1.3.

Enjoy!
Matthieu

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message