nutch-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yash Thenuan Thenuan <rit2014...@iiita.ac.in>
Subject RE: Regarding Indexing to elasticsearch
Date Wed, 28 Feb 2018 12:20:20 GMT
IndexingJob (<batchId> | -all |-reindex) [-crawlId <id>]
This is the output of nutch index i have already configured the
nutch-site.xml.

On 28 Feb 2018 17:41, "Yossi Tamari" <yossi.tamari@pipl.com> wrote:

> I suggest you run "nutch index", take a look at the returned help message,
> and continue from there.
> Broadly, first of all you need to configure your elasticsearch environment
> in nutch-site.xml, and then you need to run nutch index with the location
> of your CrawlDB and either the segment you want to index or the directory
> that contains all the segments you want to index.
>
> > -----Original Message-----
> > From: Yash Thenuan Thenuan [mailto:rit2014049@iiita.ac.in]
> > Sent: 28 February 2018 14:06
> > To: user@nutch.apache.org
> > Subject: RE: Regarding Indexing to elasticsearch
> >
> > All I want  is to index my parsed data to elasticsearch.
> >
> >
> > On 28 Feb 2018 17:34, "Yossi Tamari" <yossi.tamari@pipl.com> wrote:
> >
> > Hi Yash,
> >
> > The nutch index command does not have a -all flag, so I'm not sure what
> you're
> > trying to achieve here.
> >
> >         Yossi.
> >
> > > -----Original Message-----
> > > From: Yash Thenuan Thenuan [mailto:rit2014049@iiita.ac.in]
> > > Sent: 28 February 2018 13:55
> > > To: user@nutch.apache.org
> > > Subject: Regarding Indexing to elasticsearch
> > >
> > > Can somebody please tell me what happens when we hit the bin/nutc
> > > index
> > -all
> > > command.
> > > Because I can't figure out why the write function inside the
> > elastic-indexer is not
> > > getting executed.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message