nutch-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tony Mullins <tonymullins...@gmail.com>
Subject Re: PluginRuntimeException ClassNotFound for ParseFilter plugin in Nutch 2.2 ?
Date Thu, 13 Jun 2013 06:03:30 GMT
I have done this all. Created my plugin's ivy.xml , plugin.xml , build,xml
. Added the entry in nutch-site.xml and src>plugin>build.xml.
But I am still getting "PluginRuntimeException:
java.lang.ClassNotFoundException"


Is there any other configuration that I am missing or its Nutch 2.2 issues ?

Thanks,
Tony.


On Thu, Jun 13, 2013 at 1:09 AM, Tejas Patil <tejas.patil.cs@gmail.com>wrote:

> Here is the relevant wiki page:
> http://wiki.apache.org/nutch/WritingPluginExample
>
> Although its old, I think that it will help.
>
>
> On Wed, Jun 12, 2013 at 1:01 PM, Sebastian Nagel <
> wastl.nagel@googlemail.com
> > wrote:
>
> > Hi Tony,
> >
> > you have to "register" your plugin in
> >  src/plugin/build.xml
> >
> > Does your
> >  src/plugin/myplugin/plugin.xml
> > properly propagate jar file,
> > extension point and implementing class?
> >
> > And, finally, you have to add your plugin
> > to the property plugin.includes in nutch-site.xml
> >
> > Cheers,
> > Sebastian
> >
> > On 06/12/2013 07:48 PM, Tony Mullins wrote:
> > > Hi,
> > >
> > > I am trying simple ParseFilter plugin in Nutch 2.2. And I can build it
> > and
> > > also the src>plugin>build.xml successfully. But its .jar file is not
> > being
> > > created in my runtime>local>plugins>myplugin directory.
> > >
> > > And on running
> > > "bin/nutch parsechecker http://www.google.nl"
> > >  I get this error " java.lang.RuntimeException:
> > > org.apache.nutch.plugin.PluginRuntimeException:
> > > java.lang.ClassNotFoundException:
> > > com.xyz.nutch.selector.HtmlElementSelectorFilter"
> > >
> > > If I go to MyNutch2.2Source/build/myplugin , I can see plugin's jar
> with
> > > test & classes directory created there. If I copy .jar  from here and
> > paste
> > > it to my runtime>local>plugins>myplugin directory with plugin.xml
file
> > then
> > > too I get the same exception of class not found.
> > >
> > > I have not made any changes in src>plugin>build-plugin.xml.
> > >
> > > Could you please guide me that what is I am doing wrong here ?
> > >
> > > Thanks,
> > > Tony
> > >
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message