nutch-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Stewart" <pstew...@nexicomgroup.net>
Subject Nutch 500 Error
Date Wed, 05 Apr 2006 18:39:50 GMT
Hi there...

I was having a number of problems with my install, mainly because I'm
not used to Tomcat and/or Nutch etc...

Anyways, I am running Fedora 4 and was told that the packages are bad
idea to use so uninstalled all of my java/tomcat rpm's and installed new
binaries today from the source sites (Sun Java / Apache Tomcat)

Things are looking better I think but when I try to run a search I get
this:

HTTP Status 500 - 

------------------------------------------------------------------------
--------

type Exception report

message 

description The server encountered an internal error () that prevented
it from fulfilling this request.

exception 

org.apache.jasper.JasperException
	
org.apache.jasper.servlet.JspServletWrapper.handleJspException(JspServle
tWrapper.java:510)
	
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.ja
va:393)
	
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
	
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:802)


root cause 

java.lang.NullPointerException
	org.apache.nutch.searcher.NutchBean.init(NutchBean.java:96)
	org.apache.nutch.searcher.NutchBean.<init>(NutchBean.java:82)
	org.apache.nutch.searcher.NutchBean.<init>(NutchBean.java:72)
	org.apache.nutch.searcher.NutchBean.get(NutchBean.java:64)
	org.apache.jsp.search_jsp._jspService(search_jsp.java:112)
	
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
	
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.ja
va:332)
	
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
	
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:802)


The search page comes up fine.... I figure this must be something simple
I hope... I read on the Nutch site about utf-8 and added it to the
configuration of my Tomcat5 server... Any other ideas?

Thanks again,

Paul

Mime
View raw message