nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raf Huys <raf.h...@gmail.com>
Subject Re: Nifi 1.1.0 cluster on Docker Swarm
Date Wed, 15 Mar 2017 14:38:42 GMT
Great.
I have an overlay network listed in docker-compose, sure.
I want to narrow down the issue, so if the Nifi configuration is working,
that's already a big step.
Thank you for your time.

On Wed, Mar 15, 2017 at 3:28 PM, Jeremy Dyer <jdye64@gmail.com> wrote:

> Raf - Ok so good news and bad news. Good news its working for me. Bad news
> its working for me =) Here is the complete list of things that I changed.
> Hopefully this can at least really help narrow down what is causing the
> issue.
>
> - I ran on a single machine. All that was available to me while at the
> airport.
> - I added a "network" section to the end of the docker-compose.yml file. I
> think you might already have that and this was just a snippet in your gist?
> - I removed the COPY from the Dockerfile around the custom processors
> since I don't have those.
>
> In my mind the most likely issue is something around Docker swarm
> networking.
>
> On Wed, Mar 15, 2017 at 9:35 AM, Jeremy Dyer <jdye64@gmail.com> wrote:
>
>> Thanks for sharing! Give me a little bit to test out and I will get back
>> to you. I obviously will not have your custom processors so will have to
>> make that small adjustment in the Dockerfile but it is highly unlikely that
>> is the actual issue anyway.
>>
>> On Wed, Mar 15, 2017 at 9:04 AM, Raf Huys <raf.huys@gmail.com> wrote:
>>
>>>  Awesome, we wrap https://github.com/mkobit/docker-nifi to add some custom processors:
>>>
>>>
>>> Tx
>>>
>>>
>>>
>>> FROM mkobit/nifi:1.1.0-openjdk-8COPY . /opt/nifi/WORKDIR /opt/nifi/RUN cp dependencies/*.nar
 $NIFI_HOME/libEXPOSE 8080CMD  tail -F ${NIFI_HOME}/logs/nifi-app.log & ${NIFI_HOME}/bin/nifi.sh
run
>>>
>>>
>>> On Wed, Mar 15, 2017 at 1:59 PM, Jeremy Dyer <jdye64@gmail.com> wrote:
>>>
>>>> Raf - Glad to help you troubleshoot this. Are you using the official
>>>> NiFi docker image? If not could you please share your Dockerfile so I can
>>>> try out your configuration locally
>>>>
>>>> On Wed, Mar 15, 2017 at 6:48 AM, Raf Huys <raf.huys@gmail.com> wrote:
>>>>
>>>>> I'm having difficulty getting my 2-node Nifi cluster up and running
>>>>> with a separate 3-node Zookeeper ensemble. Part of the issue might be
that
>>>>> it's being ran as a Docker Swarm cluster (with an overlay network).
>>>>>
>>>>> In particular, I cannot connect to the UI.
>>>>>
>>>>> Configuration and logs can be found here: https://gist.github.com/
>>>>> Raffiki/0b84d916a2475aba94cae97a7f4fff10
>>>>>
>>>>>
>>>>> The logs seem to indicate that the cluster was successfully
>>>>> established however (`NiFi has started. The UI is available at the
>>>>> following URLs:...`)
>>>>> So not being able to connect to the UI might be a Docker network
>>>>> configuration issue. However: I cannot curl Nifi on 8080 on the container
>>>>> itself. So I'm stuck.
>>>>>
>>>>> What would help me out, is a doublecheck on the `nifi.properties` file
>>>>> for obvious errors. The nifi-properties file on the second node is similar
>>>>> (except for hostnames)
>>>>>
>>>>>
>>>>> Tx
>>>>>
>>>>> Raf Huys
>>>>>
>>>>
>>>>
>>>
>>>
>>> --
>>> Mvg,
>>>
>>> Raf Huys
>>>
>>
>>
>


-- 
Mvg,

Raf Huys

Mime
View raw message