nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mohammed shambakey <shambak...@gmail.com>
Subject Re: nifi at AWS
Date Tue, 24 Jan 2017 14:25:34 GMT
Thank you all.

I'm already using HTTP, and "transmission" and "ports" are open (I think
this is what you mean by nifi.remote.input.socket.port, right?), but still
the same problem.

I can access the remote instance from another AWS instance in the same VPC
(I didn't try another VPC), but from my local machine to the remote AWS
instance, transaction fails.

I tried to open all input TCP tranffic to the AWS instance, but AWS didn't
allow that. If it can't be solved, I think I'll just use same EC2 instances
running in the same VPC.

Regards

On Sun, Jan 22, 2017 at 4:04 PM, Andrew Grande <aperepel@gmail.com> wrote:

> Isn't it more advisable to use the HTTP mode instead, i.e. no additional
> ports to open? Make sure to change the client RPG mode to http from RAW (in
> the UI).
>
> Andrew
>
> On Sun, Jan 22, 2017, 10:47 AM Bryan Bende <bbende@gmail.com> wrote:
>
>> Hello,
>>
>> I'm assuming you are using site-to-site since you mentioned failing to
>> create a transaction.
>>
>> In nifi.properties on the AWS instance, there is probably a value for
>> nifi.remote.input.socket.port which would also need to be opened.
>>
>> -Bryan
>>
>> On Sat, Jan 21, 2017 at 7:00 PM, mohammed shambakey <shambakey1@gmail.com
>> > wrote:
>>
>> Hi
>>
>> I'm trying to send a file from a local nifi instatnce to a remote nifi
>> instance in AWS. Security rules at remote instance has port 8080 opened,
>> yet each time I try to send the file, local nifi says it failed to create
>> transaction to the remote instance.
>>
>> Regards
>>
>> --
>> Mohammed
>>
>>
>>


-- 
Mohammed

Mime
View raw message