nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy LoPresto <alopre...@apache.org>
Subject Re: Deleting an empty group fails
Date Sat, 28 Jan 2017 03:32:06 GMT
Makoto,

Templates are tied to process groups. Unfortunately, this means that to delete the group,
you will have to delete the templates first. You can do this by using the “hamburger”
global menu at the top right of the UI and selecting “Templates”, then deleting the templates
which reside in this process group (export them to XML first if you want to save them).

If you want to move those templates out of the PG, and you are comfortable working in XML,
a less-enticing option is to stop the application, uncompress and open the flow.xml.gz file,
and move the template entries out of the process group to root or another group, being sure
to update any references in the XML. Then save and compress the file, and restart the application.

I understand this is not an ideal solution. I’m going to file a Jira documenting this and
suggest that the dialog allows you to select one of three options:

1. Delete process group and all contained templates
2. Delete process group and move templates to parent PG (this could cause issues because the
components and connections will no longer be defined)
3. Cancel the delete operation.

I’ll also suggest improving the documentation to make this situation clearer.




Andy LoPresto
alopresto@apache.org
alopresto.apache@gmail.com
PGP Fingerprint: 70EC B3E5 98A6 5A3F D3C4  BACE 3C6E F65B 2F7D EF69

> On Jan 27, 2017, at 7:12 PM, Makoto Hashimoto <tokomakoma123@gmail.com> wrote:
> 
> Hi,
> 
> I'm trying to delete an empty group.
> 
> <image.png>
> 
> However, it fails with the following error.
> 
> <image.png>
> 
> Is something wrong with my operation and could someone would help to
> solve this problem ?
> 
> Regards,
> MH


Mime
View raw message