nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yari Marchetti <Yari.Marche...@buongiorno.com>
Subject Re: Nifi "Hive" with CDH
Date Fri, 16 Dec 2016 10:31:00 GMT
Hi Nicolas,
as Matt pointed out, it's not as easy as recompiling because of dependencies issues, in my
case I was able to recompile and make it work by brutally removing some code related to ORC
files support which we don't need (you can read more here http://apache-nifi.1125220.n5.nabble.com/Nifi-1-0-0-compatibility-with-Hive-1-1-0-td11961.html).
If it's the same it's true for you, I can send you the patch to apply for Nifi 1.0.0 (I've
still to look into Nifi 1.1.0) and you can then recompile it yourself.

@developers: is there any plan to solve look into this anytime soon?

Yari


________________________________
Da: Matt Burgess <mattyb149@apache.org>
Inviato: mercoledì 14 dicembre 2016 15.49.44
A: users@nifi.apache.org
Oggetto: Re: Nifi "Hive" with CDH

Unfortunately I don't believe enabling the profile and setting the version will work in this
case, because there are API differences between Hive 1.0.0 (the one CDH 5.9 is based on) and
Hive 1.2.1 (the one NiFi is based on). These require code changes to get working.

Regards,
Matt

On Wed, Dec 14, 2016 at 5:26 AM, Andre <andre-lists@fucs.org<mailto:andre-lists@fucs.org>>
wrote:
Nicolas,

Have you tried building NiFi with the CDH libraries?

The functionality is available out of the box and just requires you to enable to correct profile.

Cheers

On Wed, Dec 14, 2016 at 9:13 PM, Provenzano Nicolas <nicolas.provenzano@gfi.fr<mailto:nicolas.provenzano@gfi.fr>>
wrote:
Hi all,

We are currently working on NiFi Hive processors (selectHiveQL, putHiveStreaming...).

We are testing them with a CDH platform (and with a "Apache" platform).

Hive 1.0.0 is deployed with the last releases of CDH (5.9) while Nifi is built with Hive 1.2.1
libraries.

We then have serious compatibility issues. The "simple" selectHiveQL processor fails with
"required client_protocol is unset" error message, that seems to shows version mismatch between
the hive client and the hive server.

Do you know if there are workarounds or solutions for those issues ? I would like to avoid
rebuilding NiFi with older libraries.

Thanks in advance,

BR

Nicolas


-
Gfi Informatique Telecom
Nicolas Provenzano
BU Telecom / Customer Experience
nicolas.provenzano@gfi.fr<mailto:nicolas.provenzano@gfi.fr>
-
2 rue Andras Beck - 92360 Meudon La Forêt
Tél. : +33 (0)1 46 83 35 06
Mob. : +33 (0)6 82 07 19 21
www.gfi.world<http://www.gfi.world/>
-
[signature-img]




Mime
View raw message