nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Parul Agrawal <parulagrawa...@gmail.com>
Subject Need help in nifi- flume processor
Date Wed, 07 Oct 2015 06:50:23 GMT
Hi,

I was trying to run Nifi Flume processor with the below mentioned
details but not could bring it up.

I already started flume with the sample configuration file
=============================================
# example.conf: A single-node Flume configuration

# Name the components on this agent
a1.sources = r1
a1.sinks = k1
a1.channels = c1

# Describe/configure the source
a1.sources.r1.type = netcat
a1.sources.r1.bind = localhost
a1.sources.r1.port = 44444

# Describe the sink
a1.sinks.k1.type = logger

# Use a channel which buffers events in memory
a1.channels.c1.type = memory
a1.channels.c1.capacity = 1000
a1.channels.c1.transactionCapacity = 100

# Bind the source and sink to the channel
a1.sources.r1.channels = c1
a1.sinks.k1.channel = c1
=============================================

Command used to start flume : $ bin/flume-ng agent --conf conf
--conf-file example.conf --name a1 -Dflume.root.logger=INFO,console

In the Nifi browser of ExecuteFlumeSink following configuration was done:
Property           Value
Sink Type         logger
Agent Name      a1
Sink Name         k1.

Event is sent to the flume using:
$ telnet localhost 44444
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
Hello world! <ENTER>
OK

But I could not get any data in the nifi flume processor. Request your
help in this.
Do i need to change the example.conf file of flume so that Nifi Flume
Sink should get the data.

Thanks and Regards,
Parul

Mime
View raw message