nifi-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [nifi] alopresto commented on a change in pull request #4029: NIFI-6491 Improve installation instructions in Admin Guide and Gettin…
Date Thu, 06 Feb 2020 19:26:32 GMT
alopresto commented on a change in pull request #4029: NIFI-6491 Improve installation instructions
in Admin Guide and Gettin…
URL: https://github.com/apache/nifi/pull/4029#discussion_r376035063
 
 

 ##########
 File path: nifi-docs/src/main/asciidoc/getting-started.adoc
 ##########
 @@ -58,14 +58,20 @@ dataflows.
 
 == Downloading and Installing NiFi
 
-NiFi can be downloaded from the link:http://nifi.apache.org/download.html[NiFi Downloads
Page^]. There are two packaging options
-available: a "tarball" that is tailored more to Linux and a zip file that is more applicable
for Windows users. Mac OS X users
-may also use the tarball or can install via Homebrew.
+WARNING: Before proceeding, check the Admin Guide to confirm you have the <<administration-guide.adoc#system_requirements,minimum
system requirements>> to install and run NiFi.
 
-To install via Homebrew, simply run the command `brew install nifi`.
+NiFi can be downloaded from the link:http://nifi.apache.org/download.html[NiFi Downloads
page^]. There are two packaging options
+available:
+
+- a "tarball" (tar.gz) that is tailored more to Linux
+- a zip file that is more applicable for Windows users
+
+Mac OS X users may also use the tarball or can install via link:https://brew.sh[Homebrew^]
by simply running the command `brew install nifi` from the command line terminal.
+
+NOTE: NiFi requires Java 8 or 11. It is recommended that you have installed one of these
Java versions prior to installing NiFi via Homebrew. Homebrew is aware of NiFi's Java dependency
and may prompt to install an incompatible JDK as part of its NiFi install.
 
 Review comment:
   Discussed with @andrewmlim , we agreed on this wording: "Homebrew is aware NiFi depends
on Java but not the specific supported versions, so it may prompt to install an incompatible
JDK as part of its NiFi install."

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

Mime
View raw message