nifi-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Witt (Jira)" <j...@apache.org>
Subject [jira] [Commented] (NIFI-7076) Back Pressure Not Being Applied In Cluster Mode
Date Wed, 29 Jan 2020 20:30:00 GMT

    [ https://issues.apache.org/jira/browse/NIFI-7076?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17026187#comment-17026187
] 

Joe Witt commented on NIFI-7076:
--------------------------------

after discussion with markp on the purpose/intent/outcome of NIFI-6787 it is clear that the
change did not do as intended and created the backpressure issue.  So reverting that commit
in support/nifi-1.11.x branch to enable the release of nifi 1.11.1 restoring the previous
behavior.  There will be another JIRA to go after the spirit/intent of NIFI-6787 in a future
release.

> Back Pressure Not Being Applied In Cluster Mode
> -----------------------------------------------
>
>                 Key: NIFI-7076
>                 URL: https://issues.apache.org/jira/browse/NIFI-7076
>             Project: Apache NiFi
>          Issue Type: Bug
>    Affects Versions: 1.11.0
>            Reporter: Shawn Weeks
>            Priority: Critical
>             Fix For: 1.12.0, 1.11.1
>
>         Attachments: Bug_Example.xml, Screen Shot 2020-01-29 at 12.49.17 PM.png, Screen
Shot 2020-01-29 at 12.49.55 PM.png
>
>
> In the attached example back pressure does not get applied if executed on a NiFi cluster.
Single node works fine. I've reproduced this locally on a Redhat 7 based cluster with embedded
zookeeper and a Kubernetes based cluster running external zookeeper.
> This has been reproduced both with the embedded zookeeper with 1.11 and external docker
based zookeeper from docker.io/bitnami/zookeeper:3.5.6-debian-10-r0



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message